Spending tab not updating


(Jonathon) #1

This is day one of using my Mondo card so bear with me if this is supposed to happen.

The spending tab on the app doesn’t appear to be updating. I made my first transaction this morning which appeared on the tab fine, but this afternoon I’ve made two other transactions that don’t apppear.

They all appear on the home tab, just not the spending tab.

Why would one appear but not the other two?

(When I go into all three transactions on the home tab they say they are “pending” at the bottom, but this wouldn’t explain why one would show when pending but the other two wouldn’t).


Spending categories not updating
(Andy Smart) #2

Hey Jonathon!

That doesn’t sound right at all :frowning:

We don’t show every kind of transaction in spending, so it would depend on what the transactions specifically are - or it could be a bug with the caching on that screen.

If you get a chance, try force quitting the app and going back to the spending screen, that should clear the cache there and hopefully update :slight_smile:


Spending categories not updating
Incoming payment categorisation
(Alex Sherwood) #3

I’ve been having this issue & your suggestion

worked. @Yehudi was looking into this for me this morning, after I asked about it in a chat.

If this is going to be an ongoing issue, the ability to pull down to refresh the page would be good enough for me, although obviously an automatic refresh when the tab’s loaded would be ideal.


(Jonathon) #4

One was shopping (clothes) and one was eating out (Pret). The initial transaction was also eating out (a coffee).

Force quitting and going back in seems to have fixed it (though not a very practical thing to have to keep doing!)


(Andy Smart) #5

Thanks guys, that sounds like we have a cache invalidation issue here somewhere, I’ll add a card so we can get this fixed, but we have some pretty big enhancements coming to spending real soon :wink:


Known issues / bugs 🐛🐜🐞
Known Issues + Bugs iOS Specific 
My card app still thinks it's August
(MikeF) #6

Ah, excellent. This was what I was coming in here to report. Force quitting does sort it, thanks.


(simon1) #7

Hi, I also have this issue. The spending tab is one of my most used features, so this is a super annoying bug for me. Some feedback on when you expect to fix it would be really appreciated, thanks.


(Alex Sherwood) #8

It’s a pretty safe bet that @andys is referring to the new target / budgeting functionality which Tom mentioned in the Periscope Chat yesterday -

& which he said will be released in the next few weeks. So by the sound of it, this issue will be fixed then too.


My card app still thinks it's August
Known issues / bugs 🐛🐜🐞
#9

Came to report this issue and force quitting fixed it, not a permanent solution though.