Updating "Your Spending" Automatically


(Charlie) #1

I just placed an order online, and after receiving the notification (almost instantly :boom:), I swiped :point_left: it, and entered the app.

I was initially surprised to land on the “Your Spending” screen rather than the transaction itself, which is fine (and may have been the result of leaving the app on this screen). However, my issue was that “Your Spending” had not been updated with the transaction I had swiped :point_left: on (from the lock screen) to enter the app. In order to resolve this, I had to hit “Mondo” in the top left corner and swipe down :point_up_2: on the transaction overview page to refresh the feed. I then clicked “Your Spending” again, and it had updated accordingly.

I would be interested to find out if anyone else has experienced this behaviour?


(Dom B) #2

Sounds like the difference between the push notification and background app refresh. Push notifications can be used to trigger the app to perform a function (like refreshing the your spending feed) so maybe it’s not set up to do that yet?
Have you got Background App Refreah enabled for Mondo? It’s in the Mondo options in Settings.


(Charlie) #3

Good suggestion - I currently don’t have “Background App Refresh” enabled (I like to save :battery:), but will put this on and see if this changes the behaviour.

However, I guess a key issue (from a usability perspective) was the workaround for refreshing “Your Spending” which requires going backwards and forwards between the two feeds.

In the long term, it might be useful to add the functionality to refresh “Your Spending” from the page itself, or even using the push notification trigger as @dombarnes mentioned!

Edit: I’ve just noticed the new update (1.4.1) which should fix this issue.