Monzo and McDonald's App

Issue: Tried paying for order through McDonald’s app. App flips to Monzo app for authorisation, but then bounces back to McDonald’s app before opportunity to accept or decline transaction has been provided.

Details to reproduce: Try using Monzo as payment method for app based McDonald’s order
OS: Android
Device: Huawei
App Version: 3.9.0

Had been working fine, so don’t know if the issue is at Monzo end or McDonald’s

Worked fine with my Starling linked card though :man_shrugging:

I’ll have to test this myself next week, haven’t noticed any problems yet but I have had a week off McDonald’s.

Have either of the apps been updated recently?

I take it you tried switching back to Monzo to see if you could resume the auth there?

It worked fine for me last Wednesday - but that was on 3.89.1 - I haven’t used the McD’s app with the Monzo card as the payment method with 3.90.0 yet and have no plans for McD’s today. Unless the :hamburger::fries: temptation rises later.

Yeah. Nothing in Monzo app at all.

Occurred Wednesday and yesterday.

Wednesday, for a coffee

Yesterday, to use the 99p deal for quarterpounder :grin:

Neither anywhere near balance of my account, so not that either. :man_shrugging:

Same issue here, tried to use McDonald’s UK app for first time this morning. Unable to add card because when it goes to save card details and make a 3DSecure call, the monzo app opens but doesn’t do anything.
Returning to McDs app, card details no saved, repeated this 6 times just won’t work.

Added a card from another bank and it worked immediately.

Something is broken with Monzo’s 3DS stuff, somehow.

1 Like

Yeah, I just use my Starling card now.

Have you contacted support using the in app chat to report this? Would recommend if you haven’t done so already.

Reported in app and waiting for comment from Payment Team.

CS did suggest verification via SMS, however, I informed her that this option did not appear to be available with the McDonald’s app.

She also confirmed that there were no recent changes (that she was aware of) that could cause this.

1 Like

We just experiences a issue with 3d secure using the Domino’s app. Previous it had worked fine however today when we used it, the 3d secure check appeared in the Domino’s app and prompted to open the monzo app to approve. Approved it as normal in the monzo app which showed the transaction as pending and returned to the Domino’s app as normal however, instead of progressing the screen in the Domino’s app was stuck on a plain white 3d secure screen with no other option but to cancel.

Tried it twice which resulted in 2 lots of authorisations and no order but fortunately they reversed themselves after an hour. Ordered using a different bank card and it went straight through.

1 Like

Nice to see the kind of issues I’ve had with various websites for a while is spreading :sweat_smile:

Last time I contacted chat, it was a pointless exercise. It’s only random for me so only minor impact on my usage.

1 Like

I’ve had loads of issues with monzo and approving payments recently.
It all seemed to work fine but something seems to have gone wrong recently?

I’ve stopped trying for now. Added my Barclaycard and will use that for now

I’m having same issue, support just told me to use another device, I said with all due respect - most people like me don’t have more than one phone. Thay then asked me to do it online. But you can only use the app.

I just opened the app (HotDeals said there was a good offer) and it had a notification about an error last time I used it. But that was fine and they charged me? :man_shrugging:t3:

They’ve just given me the same advice.

Told them to not worry about it, I’ll just use a different card.

Another reason to use Monzo less.

Wont need my account much more at this rate tbh.

Most by DDs are elsewhere now, so even bill pots are of little use tbf.

1 Like

That’s pretty much how dismissive they were of my similar issues months ago. Hardly inspires confidence.

So after multiple failures last week, I’ve just tried to use my monzo card with McDonalds again this morning and it immediately worked.
No redirect to Monzo app, it just went through immediately without prompting.

Exit: No I am wrong, still didn’t work, although it did a bit more than last time and allowed me to save my card details in the app, and Monzo shows an active card check both from Google and McDonald’s, but on trying to take payment, sent me to Monzo app with nothing to select to auth the payment, so it failed again.

Had to use alternative bank card still. Very disappointing.

Ahhh, so it wasn’t just me!

I used to have this all the time and switched to using Apple Pay instead (which just charged me through my Monzo account) and that worked. I hadn’t appreciated that this was a general Monzo/McDonald’s problem.

It looks to be something to do with the latest update to the Monzo app, mine was working on the McDonalds app Monday, Monzo app updated Tuesday, now no longer working in McDonalds app!

I’ve received a CS Feedback request today for this unresolved issue.

What sort of feedback do they think they’re gonna get? :man_shrugging:

Last advice I was given was to use a different card :man_facepalming: