Debit card weirdness

There is something weird going on with my debit card when I’m using it online. I tried to make payments last night on my android device and a website redirect appears and the monzo app opens. No payment is going through. I’ve had this with the Kinguin website and the Mcdonalds app.

Both times I have had to use alternative providers to make the purchase after several attempts. In the cases mentionrd CJ’s CD keys through PayPal for the kinguin purchase and uber eats instead of McDonald’s. On both of these occasions there has been an active card check after the payment actually went through.

Also the website redirect is actually opening the monzo app on my phone I dont know what that is about. I tried to get a screenshot of the url the mcdonalds app redirected me to but was never fast enough to capture the screenshot. It contained something like arden.checkoutstopper in the URL and then the monzo app would open.

The payments didn’t give me a declined notification on the Monzo app, they just didn’t go through. I tried the Mcdonalds order about 5 times. The kinguin order showed as pending and then I got an email saying the payment had expired.

But why are random websites able to open my banking app and why are there active card checks after every payment I make online after the actual purchase?

It’s normal.

1 Like

This is not the 3d secure process though. I’ve not been living under a rock.

There is no notification that a payment was ever even attempted and no 3d secure redirect on the merchants site.

And active card checks 3 minutes after a payment is taken every time I make one? Normally there is one before.

.checkoutstopper in a redirect link. Never seen this before.

I assure you, it is. The Monzo is opening for you to authenticate the payment.

1 Like

I assure you it isn’t.

How is not physically being able to make a payment “normal”

When the Monzo app opens, are you waiting for it to finish loading before trying to return to the website?

You should be seeing the app request that you approve the transaction, either straight away, or via a request near the top of your feed.

The blog I linked to has screenshots of the screens.

I’m very familiar with the 3d secure process I use it every other day. There is no 3d secure landing page on the merchants website and no notification in the monzo app that I can tap to approve. The payment has simply not gone through.

I dont know if the websites/apps are attempting to launch 3d secure and the process is not working. Either way I’m unable to make payments through these merchants.

There is also another thread by someone posted earlier that cannot make a payment through the McDonald’s app. So its not just me, but its not just McDonald’s, its other websites too.

2 Likes

Ok, if that’s the case it could be something has broken with the implementation of 3DSecure. I reccomend you use the in-app chat function to report the issue to Monzo customer services for them to investigate.

1 Like

My experience of 3D Secure is the message in the little window telling me to go to the app along with the notification that the transaction is waiting. I think.

I’ve never had an attempt to pay directly open the app so I agree that there seems to be something screwy here.

Yeah thats exactly what happens to me every other time I have had it. The website redirects to a 3d secure page that says open your monzo app to approve the payment.

I have never had a chrome webpage or 3rd party app open the monzo app on my phone.

Yes I’ve never been redirected to the app normally get a page asking you to approve in app and then the monzo notification pops up to go in and approve so something is strange here I had a regular card payment not go through the other day monzo said it was because the billing address was wrong but I had no notification in app just a email from the person I was paying and I have successfully paid them before last month and no details have changed

1 Like

No reports of issues for months then suddenly:

@arthur-ceccotti maybe worth you taking a look?

1 Like