Wear OS Google Pay failures


(Allie) #1

I had two failures of Google Pay in Wear OS. TK Maxx and Tesco (I’ve previously used it at Tesco ok). ‘See phone for instructions’ (like for PIN entry CDCVM). At TK Maxx there were no instructions on my watch. At Tesco it said to unlock my phone to pay. This would kinda defeat the point of paying by watch, but it didn’t even work. In both cases my phone worked fine. These were my last two payment attempts so I don’t know if it’s totally broken lol.

I’ve asked chat for help but haven’t heard back yet. Has anyone here seen this?


(Simon B) #2

I don’t have any personal experience since my Wear OS watch doesn’t have NFC but I can’t say I’ve seen many reports of this coming through on support.

Did you get a decline in your app? If not, we won’t have much specific information to go on but we can cross reference with any similar ones to dig deeper. Let us know when you hear back from chat.


(Allie) #3

Thanks Simon, nothing in app. It just happened AGAIN but this time my watch had me confirm my pattern (it was already unlocked…) and tap again and then it worked. Still so tricky as to be pointless.


#4

I’ve only ever had a problem with Google Pay (on phone mind you) when trying it with an early Android Pie beta version. And also when reverting back to a stable version. Readding the cards seemed to fix it. I imagine you’re having a different issue though. 🤷


(Allie) #5

I have had no issues on my phone, ever.


(Allie) #6

Well COps told me to remove and re-add my card. I did this and also completely reset Google Pay’s data for good measure. It worked fine for the first two transactions of the day, then on the third (only £1) transaction I got the same error on the terminal but unlike yesterday my watch asked me immediately to enter my pattern and tap again.

It worked. But what a pain. Is this the expectation with Google Pay on a watch? This is with the watch unlocked I will note. I can get out my phone or card quicker than this double tap mess…


(Simon B) #7

We’ve just been made aware of a similar issue with Apple Pay so we will investigate whether this is an MDES issue in general. We aren’t getting a lot of reports for either platform so they may be unrelated data points but we are looking into it.

EDIT - Ignore the above, someone wrote Apple Pay instead of Google Pay on an escalation :man_facepalming:

We are still investigating!


(Allie) #8

LOL looks like it might be my escalation? It totally failed at Superdrug but showed in the feed. Lots of weirdness with a very high failure rate. Many thanks for your help.


(Simon B) #9

I’m half tempted to trade in my LG Watch Style for something with NFC to start testing this myself… Maybe after payday, and if Google launch something at their event next month!

What device are you using btw?


(Allie) #10

A Fossil Q Venture HR 4th gen.


#11

I was tempted by that one. Definitely has most of the features I want and actually looks nice.


(Allie) #12

It is. I wish it was a little thinner and a little better battery life.


(James) #13

I experienced the very same thing yesterday on my Huawei Watch 2.

l was in Tesco and had to unlock my phone then tap the watch again.


(Allie) #14

Definitely seems to be a more widespread problem then…


#15

I have the fossil q venture hr bought last weekend. My watch failed in Sainsbury’s yesterday I thought it was me.


(Allie) #16

We both bought the same watch last weekend! Which colour did you get? I almost got the really sparkley one but ended up getting the rose gold with grey strap to match more outfits, and got a black and purple strap on Amazon to liven it up a bit!


#17

I bought the silver one with the brown strap so that my watch goes with all my stuff.


(Allie) #18

I used my Amex card all day with no issues (except at shops like TK Maxx that don’t take Amex contactless in any form), including two high value contactless purchases. Switched back to Monzo, went into Superdrug, and same issue (pattern unlock on watch, just paid with phone since it didn’t come up immediately). The watch was already unlocked to start with, and again Amex was flawless all day so it’s either a Monzo issue or a Mastercard issue. I’m on holiday in Bristol so can’t try another Mastercard until next week (don’t have the security code memorised).


(Marc Roberts) #19

I am also having this problem. Using a new Skagen Falster 2.


#20

I started having the issue a couple of months ago with Starling. The frequency of me having to put my pattern in the watch and retry has slowly been increasing. I don’t use Starling much anymore, but my Monzo card does the same. I sometimes get the same with my phone (really annoying at the tube on a morning) but it occurs with far less frequency than using my watch.

At first I thought it was the first watch transaction of the day, but I’m not convinced. The watch is definitely already unlocked when it happens (I unlock it when I put it on and it only locks again when removed).

For clarity, I’m talking about transactions under £30. I’m aware of the requirement to unlock for higher value transactions.