You can no longer pay in shops with Google Pay

Yesterday afternoon I made a payment in a local cafe with Google Pay, which went though perfectly fine. However when I tried to pay on a bus last night I got the message “You can no longer pay in shops with Google Pay”. I also got the same in Morrisons this morning and managed to screenshot the message:

I can’t seem to find anything online to suggest Google Pay has been discontinued so am wondering if its a Monzo issue or an issue with my OnePlus 5T.

I suspect it’s probably an issue with my device as I use LineageOS, a popular open-source Android distribution. I know Google only “tolerate” the various popular Android distributions these days.

However my device shows as certified for Play Protect in the Google Store and passes Google’s Safetynet checks.

@MattHillUK Have you contacted customer services in app or tried removing and then re-adding your card in Google Pay?

I’m wondering if you’ve frozen your Monzo debit card in app?

I’ve just used Google Pay/Monzo in Morrisons with no issue so it looks isolated. The message suggests, as you said, like Google has disabled it on your device? I’m no expert though :sunglasses:

Id imagine it’s probably to do with LineageOS to be honest, like you say. You’re not on a fairly new or beta version at all?

1 Like

I had this on my Citi Corporate Visa on Friday night. I got an email five minutes later to say it was fixed… :man_shrugging:

I updated my phone to a newer version of LineageOS and re-added my card to Google Pay, everything seems ok now! :smiley:

Bit of a strange one, however thank you to everyone who offered advice.

1 Like

I also have this issue on the Oneplus 6T right now.
It wont let me pay with Android Pay but I’m using stock with Magisk.

Even readding isnt working, even though its hidden - Any idea?

I had the same issue with all my cards on both my rooted phones, since others have had the same issue going to assume Google have changed their root detection so magisk hide no longer works.

A temporary fix for me was turning off internet connectivity but once it is declined once it will continue to be declined.

Still works on my Pixel 3 XL which is rooted… Its sooooooooooooooooooooo weird!
Same version of Android… Same version of GP & Magisk…

Mine are both Nexus 6Ps running 9.0 Pie and same latest Play Store and Pay apps.

Quick search on Reddit shows some people having the same issues recently too with one user fixing it by clearing the data on the relevant Google apps (https://www.reddit.com/r/GooglePixel/comments/aweknr/comment/ehngt1e) which I may try soon.

Right so after a big of deeper digging it seems that Google Play Services have updated recently which includes a update to the SafetyNet detection meaning that if you haven’t experienced this issue you should remove auto-updating from the Google Play store and if you have you should downgrade Google play services by following the guide here (XDA Developers).

Figured it might be something Google had done…

it’s worth trying to delete the card and add it again so it generate a new card number

Hi,
Good to know that it’s sorted for you.

Just to update, last I used Google pay contactless on Sunday (3rd) afternoon at Tesco with no issue at all.
(Pixel 2 xl, not rooted and with latest update)

Thank you.

You can check if you have triggered SafetyNet in Google Play.

It will show “Device is not certified” at the bottom of Google Play settings.

It seems to work for 1 or 2 payments after that shows though

Just an FYI, this is a bug with Magisk Hide.

The Canary branch of Magisk has a completely rewritten Magisk Hide, I had the exact same problem until I jumped on the Canary version and it is working spot on again.

Magisk > Settings > Update Channel > Custom > Input below link (GitHub link)

https://raw.githubusercontent.com/topjohnwu/magisk_files/master/canary_builds/release.json

2 Likes

Really, the problem here is that Google’s error message is useless.

Cheers @stevob21 for the Canary build link.

1 Like

I’m having problems ita displaying I can’t use in shops for contact less no idea how to fix this

1 Like

Are you rooted Ben? Or perhaps you just have a phone without NFC?

1 Like

Thanks for reply. It’s a Samsung S8 it’s been used before on Google pay. I’m unsure how to fix this