Updated to Monzo Bank 2.63.0 (557) for iOS now cannot login


I updated to Monzo Bank 2.63.0 (557) for iOS now cannot login.

The e-mail that is supposed to have a magic link simply doesn’t arrive. I have asked for it to be resent, waited, checked my spam. confirmed my e-mail is working and e-mailed help@monzo.com and no response.

What can I do now as I have no access to my app to use in app chat.


Hi Andrew :wave:

Have you tried calling the number on the back of your card? Also the old uninstall, restart, reinstall and check your account at https://web.monzo.com/

1 Like

Thanks CJ, I have been looking for a phone number to ring on www.monzo.com but couldn’t find one and I hadn’t looked on the back of my card.


also, I tried to log in to the link you posted but of course it won’t let me because again I need to get the e-mail with a magic link which doesn’t arrive. I hadn’t realised the authentication relied solely on a link in an e-mail which I don’t seem to be receiving. Wow that’s a lesson learned!

Thanks again for your advice.

No problem, good luck getting back in :slightly_smiling_face:

1 Like

Hi Andrew & welcome to the community :wave:

Folllowing the steps here may help; Monzo App sign-up/login/access issues - common things to try

1 Like

Thanks David,

I tried those steps but no joy, I simply do not receive an e-mail verifying my e-mail.

So much for 24hr service from Monzo, no response when e-mailling, no response on Twitter and no response to calling. No sure Monzo is such a good bank as I thought it was.

Grateful to the community here for assistance.

Did your Monzo app work OK just before you upgraded?

1 Like

Yes, it has been fine since joining 28 months or so ago. For some reason the system doesn’t seem to send a verifying e-mail. This has been no problem in the past but seems that something is broken somewhere. I can’t even change the e-mail address to try another e-mail because I need access to do that.

I assume that if/when I get through on the phone human intervention will be able to help me get into my account?

Go into TestFlight and go to builds and download the old version 2.62 and try that?

1 Like

Hello All,

I rang the number again on the back of my card and got through to a super helpful agent. Having confirmed the verification e-mails were being sent but not received we tried several different ideas and in the end nothing worked so I asked to change my registered address. This was done by sending a picture of my photo ID to help@monzo.com. Within a few minutes the same agent rang me back and my registered e-mail address had been updated. When I tried to verify again using the new e-mail it went straight through 1st time.

My thinking is that this is not a problem with Monzo per se, rather the Monzo system simply doesn’t like my original e-mail address but nothing to do with spam. It is a weird one.

Once I talked to the Monzo agent things were solved very quickly indeed.

Thanks for all your help and tips here in the community.



I thought I would check back in to provide an update in case anyone else has the same experience.

After some extensive research with some of the Monzo engineering team my existing e-mail now works.

I can only conclude that there is something in the domain name that the Monzo e-mail system did not like. It was an e-mail address with my own domain so it is possible that the set up on my ISP side was not correct.