Unable to log into in - Urgent

Yesterday, randomly and for no apparent reason, I was logged out of my Monzo app. I have never had this happen before and used the app as usual only a few hours previously to send a payment. Next thing I knew I opened my app to check balance and it’s asking me to log in (?!)

The problem is, I enter my email address… I wait for the email to arrive as instructed, then I click the button in the email but then I get an error!

I AM clicking the link in the most recent email each time. I have tried multiple times since yesterday evening yet every time a new email is sent and I click on that newest email I just get the same error.

I am now extremely frustrated and worried. I can’t access chat because I can’t log in. There doesn’t appear to be any secondary way of logging in when this email system in place doesn’t work like this. I tried emailing Help@monzo.com yesterday evening and marking it as urgent but still have not had any response.

This is my main bank account and it is essential I have access to it. Although I’ve had an Monzo account since 2016, I am seriously thinking the switch to monzo was unwise now I’ve been left unable to access my account like this.

Can anyone offer a way of getting urgent help from Monzo without being logged into the app?

Thank you for any help and advice

There is a number on the back of your card which you can use to call Monzo. Usual steps to resolve this are:

  1. Delete the app
  2. Restart your phone
  3. Reinstall the app
  4. Delete all previous Monzo emails
  5. Try to log in.

The reason for the sudden log out was a blip Monzo had yesterday which has now been resolved.

There was a temporary problem yesterday that caused some users to be logged out.

Have you tried deleting all magic link emails from your inbox before requesting a new one?

There is a phone number to call on the back of your Monzo card if you are still unable to fix the issue.

You can phone the number on your card or email help@monzo.com

But try uninstalling and reinstalling the app first. It’s quick and often solves this sort of issue.

Thank you, I have done all of this already but no joy. Thank you anyway :slight_smile:

Thanks, I didn’t know this! Duh! I’ll try calling. Thank you :slightly_smiling_face:

1 Like

No problem :slight_smile:

Then your only option is to wait for an email response or give them a call :cry: Hope you resolve it soon :crossed_fingers:

Don’t forget that you can log into web.monzo.com too if you need to do anything urgently.

  1. Fix that horrendous font


It looks like the Disney font?

*hopefully from the silence, the OP has sorted this now and we’re not making it worse.

Did you get this sorted? I have the same problem since yesterday.

Hi Miss Twiz

I have the same problem - been nearly a week now with various bodies telling me to delete emails etc which never arrive! Latest is to ask me to change my email account!

Help desk is quite hopeless with no one really in contact with the Monzo programming system which sends out the “magic” link.

I will try speaking to someone or failing this will contact Tom Blomfield, the MD.

Some suggestions were given earlier in the topic, which ones have you tried?

I doubt Tom could help with this, in app chat is your best bet where it will get escalated to a specialist :slight_smile:


I have tried all suggestions - checking trash/junk mail, deleting app and re-installing, asking for re-send of magic email, Monzo apparently sending their link from another source - all to no avail. My email is with BT business.

@JoeObrart These “magic links” typically work by generating a unique string that has a one-time use in place of a password. I suspect the error message you’re seeing is indicative of the link having previously been clicked or the magic link string does not match what the service is expecting. There’s two likely culprits here: either an issue on Monzo’s end (possible but unlikely) or your email provider/client is tampering with the URL which is unintentionally breaking it. The way your email provider could be tampering with it is two-fold, either they could be causing the URL to be malformed when you click on it, or they’re doing some sort of automated scan against all inbound URLs which is registering the URL as having been used on Monzo’s end.

The fact that you’re using BT business email leads me to believe that is the likely culprit, as typically business email providers have much more aggressive anti-spam + anti-fraud set up than consumer email providers.

I’m not sure of the next steps to resolving this for you because it would require that you share the link you’re receiving so that we can determine if it has been altered in some way however doing so would risk your account security so you absolutely should not do that. I would recommend speaking to your email administrator to check what security settings they have enabled, and perhaps ask for the help of someone who works in IT that you trust to review the emails to determine if the link is being malformed.

1 Like

I agree with this. It’s certainly worth a try to quickly switch the email address to a personal one?

If that works then we’ve narrowed down the cause to your BT business email address and we can look at perhaps whitelisting Monzo emails to allow them through :slight_smile:

1 Like

Thank you for your email.

Not so simple here to contact email provider as my iPhone is on the O2 network and the email is BT business and any problem with a download falls between the two organisations, with each blaming the other!

It was sorted in the end :slight_smile: I had to make sure I’d deleted all previous magic emails from my inbox. Uninstall app and reboot phone. Reinstall the app and ask for a new magic email then it worked!


@MissTwizz Have you tried to delete the emails and clearing your cookies/browsing history, before trying to log back in ? I remember this happening to me a month or so ago and i tried the delete and switching my phone off to no success. clearing my cookies and history seemed to work for me.
I cant really explain how and why this worked for me but may be worth trying, could of been shear luck.

The post directly above yours is from the OP and they explain how they sorted it.

That was 5 months ago too :wink: :smiley: