[Trying to sign a new user up] List of addresses never reach the end of the list

Issue:

I’m trying to sign my mum up to a monzo account and I’ve reached the “Home Address” page, where it asks for Country of Residence, Home postcode. Every time I put our home postcode in, the list of addresses never reaches the end (where our address can be found)

Details to reproduce:
OS: Android
Device: Samsung A51
App Version: The latest as of (20/7/20)

Screenshots:

I’d rather not give screenshots of our address, however just as an example -

The addresses that come up come up under this format:

(Number) (XX Road), (City)
all the way down to number 26, and we want number 32.

I have checked the royal mail register and our address IS on the register.

I have also checked using the address that I have previously used to sign up, and I noticed this is an issue even with this address, even though 3 years ago that address processed fine. This leads me to believe its an app issue.

May I receive guidance?

There should be an option at the bottom for “My address is not on this list”

ETA:

1 Like

Hi, thank you for taking the time to respond. I have tried that option and it gives me instructions to tell Royal Mail that the address isn’t on their database. However I have checked Royal Mail’s database and the addresses I tried are on their database. This means that it may be an app issue, and that the form list isn’t long enough to hold all the addresses under a postcode.

1 Like

Ah, that’s a bit clumsy. If it’s not showing any way of contacting Monzo, then I’d suggest emailing help@monzo.com asking the question that way. It may take a few days to get a reply, though.

I hope you manage to get it sorted out.

Hi, thank you for forwarding the email address - no problem at all.

Hi Alicia,

I would try to sign up on a device with a bigger screen or different operating system instead of waiting for a response from support which can take abit if it’s over email.

But do submit the bug to support so they can fix it for others.

I have replicated this issue on Android (5.5 inch screen) and iOS (4.7 inch screen), Through both the new account sign up and the change of address section within the app.

Hi, may I know if your problem got solved? I experience the same problem as what you mentioned! Tried with different devices (iphone,samsung) but still failed to find my house number in the list of address, but my address is in Royal mail’s end.

Still waiting for them to respond, will let you know!

1 Like

I sent an email to monzo support. After waiting for 4 days, I receive an useless reply as follows. I don’t have interest to try again as they are just NOT listening to what I said in the original mail…I already told them my address is in Royal Mail database, it definitely is Monzo’s problem.

Quote:
I’m so sorry for the delay in getting in touch, we’re dealing with a high volume of email requests at the moment. I’m also really sorry to hear that you’ve had trouble trying to get a Monzo account recently.

The addresses in the app are from the Royal Mail database. If the address isn’t on the list, we won’t be able to offer an account. I’m really sorry about this !

To bypass this, you can contact Royal Mail to have your address added to the list. You could then try to sign up again 10-12 days later. I appreciate this is frustrating, but I believe this would be the only way to get an account. Would you be able to try this?

End Quote

This is incredibly irritating. They clearly have a UX issue and the fact they’re failing to recognise this is definitely a problem.

1 Like

Hi again, check the list again! I’ve checked and they seem to have resolved it and the full address lists are now there. :slight_smile: