Push notifications not sent [Android]


#1

It’s been about a week since I received my Monzo card and I noticed that I never received neither a text nor a push notification for any of the payments I’ve made (about 10). The setting in the app (I’ve got the latest version and I even re-installed it just to be sure) to allow notifications to be sent is ON and push notifications on my phone are On with no exceptions for the Monzo app. I’ve got Android 6.0.1 and I am able to receive push notifications when topping up my card only. Is this happening to anyone else?


Android app - long way to go
(Josh Bray) #2

I would check your doze settings. Doze will put apps into a deep sleep. Make sure you tell it not to optimize monzo


(Marcel W.) #3

@Original_Username Make sure to have Google Play Services enabled. Do you get notifications for other apps?

Sometimes it helps to restart the phone or even reinstall the app.


#4

Thanks both. I’ve whitelisted Monzo from Doze’s effects and enabled notifications for Google Play Services. Other apps such as Facebook, WhatsApp, etc. receive notifications without any issues so it shouldn’t be a wrong general system setting. Will let you know if that helps


#5

I’ve got an update on this. Last night I used the card to pay in a restaurant after following your suggestions but with no luck. This morning, I paid my coffee with Monzo and bam! I received a notification straight away, which suggests me it was a bug that needed a simple fix. Hopefully the fix will last! Thank you all for your suggestions


#6

Right I spoke too early apparently. Purchased other two things and no notification :sweat:


(Marcel W.) #7

Could be a possible bug.

Just to confirm, do you have a good internet connection when purchasing the item?

Also I know if sounds old-school, but a reinstall does often the trick when I have issues with apps.


#8

Hi Marcel. Yes I did have a good internet connection and I had already previously uninstalled and reinstalled the app. I’m quite sure it’s a bug, just hope for it to be thoroughly looked into as it’s a core feature, especially when abroad :slight_smile:


#9

Today I didn’t even receive the notification after topping up the card, which I used to. I’m really wondering if anyone else is experiencing this with Android or any other OS.


(Alex Sherwood) #10

Since the steps that others have suggested here haven’t fixed this issue, I’m afraid it looks like you’ll have to check with the support team to see whether they’re aware of the issue & a fix or to get a bug report opened.


#11

Out of curiosity, which phone do you have?

Is it modded in anyway?


#12

Xiaomi Redmi 3S Prime…Not modded or rooted in any way…Original MIUI 8.1.1.0…


#13

Intermittent issues are the worst.

I had a similar issue with another prepaid card app. It was solved when I whitelisted the app / battery optimisation.

But since you’ve done that already, it’s hard to know what else to try. Sorry I can’t be of help here.


#14

Yeah I think I’ve tried every settings combination without joy…Thank you for your feedback anyway Justin, appreciate it.


#15

Title says Push notifications not sent. Assume they are actually sent? and that title should be Push notifications not received?


#16

I can’t know whether they are actually sent at this stage, until it gets investigated further at the server level. However, logically, because I seem to be the only person experiencing this issue, I assume they are indeed being sent but the result is that they are not being received.


#17

Hi there @Original_Username.

I am another Xiaomi user and am experiencing similar issues to yourself so you are not alone!

I have a Xiaomi Mi5 original MIUI 8.1.2.
(Got the card a few days ago)

As for me, my notifications do not appear while connected to mobile data but as soon as I get home and turn Wi-Fi on, all new notifications suddenly appear.
Is this the same for you or can you not get any on wifi either?

I am in the process of going through all steps I’ve found on the internet relating to this and testing each one so we can hopefully help each other…

Many seem to be variations on battery optimisation as you’re probably already aware.

Perhaps you could list all different steps you’ve tried so far?


#18

I wonder if it’s because Monzo does not have a service running?
If you go to installed apps -> Running, apps that I receive instant notifications such as whatsapp, messaging app, mailing app, all have at least 1 process running.
The next column along is Cached apps which is where Monzo is.
However after a while I think Monzo disappears from cached list so I think that is why (our phones?) fail to prioritise notifications?
Any ideas if I might be onto something?


(Josh Bray) #19

This is the case, as of 6.0 (I think) Doze became a lot more aggressive and so apps need to specifically need to ask to be excluded from optimisation otherwise it will just put them to sleep


#20

So you think it might be a case of the Monzo app needing a service or equivalent to keep Doze from casting a sleeping spell on it?