Payment approval notification no longer appears on Android app

It used to be that whenever I made an online payment which requested approval via the Monzo mobile app, my Android app would receive a push notification and I could instantly tap the Approve button.

However at some point in the last few months (possibly but not definitely when I switched to a new Android phone), this stopped happening, so now the onIy way I can approve the payment is to manually open the Monzo app, scroll through the list of recent transactions until I see the one pending approval, tap on that, and then approve it.

Of course I’ve double-checked all notification settings both a) within the app and b) within the Android system’s notification settings for the app, and all are fully enabled. So what am I missing? Is this a bug which has crept in? Thanks!

1 Like

Did you install the Monzo app cleanly to your new phone, or did you transfer everything over from your old phone? Is the number/SIM the same and everything?

1 Like

I still receive push notifications on my Android phone.

It definitely sounds like some sort of setting you have on your phone that is stopping these from coming through or some privacy setting.

I received an Android system notification the other day that gave me a list of apps that I rarely use and that they’re going to supress their notifications. I didn’t have this on my old Android so it could also be related to what you’re describing. I imagine there is a setting for this somewhere too.

1 Like

Also check battery optimisation, most phones tend to come with that switched on these days. It can often kill the apps in the background which then stops notifications coming through.

It differs from manufacturer to manufacturer as to how harshly it controls background apps.

3 Likes

Those are exactly the settings I have already checked.

Yes it did cross my mind that battery optimisation could be the issue, even though it never was before. OnePlus phones tend to have more aggressive optimisation, but then my last phone was OnePlus too, and I didn’t have to disable battery optimisation for Monzo on that one. But I’ll give it a go and see if it helps. Thanks for the suggestion.

1 Like

Check the Monzo app notifications too. I’ve had specific toggles de-toggle for unknown reasons before. The following guide may differ depending on the Android version and Launcher used, but it may help:

  1. Long press on the Monzo app icon and tap on ‘App info’

  2. Tap on ‘Notifications’

  3. Ensure all toggles - or the specific ones you actually want - are enabled (I believe the ‘Important’ toggle is the one for approvals):

Boy, do I wish the in-app counts of notifications for credits and debits were reversed…:money_with_wings:

If this doesn’t work, the usual log-out of :monzo:, uninstall the :monzo: app, reboot the device, download & install the :monzo: app & login again should clear any such ‘funnies’

3 Likes

I already tried all that, with the exception of reinstalling the app. And it turns out that I already had battery optimisation disabled, so that’s ruled out too. Seems pretty clear it’s a bug - reinstall of the app should never be required, but I will try it anyway.

I don’t think it is that clear. It seems to be working fine for everyone else on Android.

Reinstall of the app is always good practice when you’re trying to shake down issues like this.

I think it was installed as part of the standard setup of a new Android phone, when it installs all the apps you were previously using, based on your Google (Play) account. Yes same number and SIM.

Well, an issue doesn’t need to occur for multiple people to qualify as a bug :slight_smile: I agree that in general if only one person is experiencing an issue, that tends to signal that it’s more likely to be user error. But I’ve already triple-checked all notification settings and disabled battery optimisation, so what are the remaining possible causes, other than it being a bug?

Sure, I’ve just done that; time will tell whether it helps. But if a reinstall is required to fix an issue, that’s a bug IMHO.

I can confirm that the reinstall fixed it. Hopefully they manage to fix that bug so a reinstall is not necessary in future.

2 Likes

Thanks for updating everyone with the positive news.

The usual log-out of :monzo:, uninstall the :monzo: app, reboot the device, download & install the :monzo: app & login again dance :bananadance: usually works to clear unknown cacheing/glitches/local-lock-ups which may not necessarily be bugs in the app.

1 Like

Thanks for the tips. IMHO unknown cacheing/glitches/local-lock-ups are all bugs, and I struggle to see how they could be classified otherwise. Wikipedia defines bugs as follows:

A software bug is an error, flaw or fault in a computer program or system that causes it to produce an incorrect or unexpected result, or to behave in unintended ways.

It’s your phone. Not the app.

How do you know that? And if so, why have I not needed to reinstall any other apps?