Push notifications not sent [Android]

I’ve been using my monzo card for just over a week and the notifications seem to have stopped. I haven’t changed any settings on my Huawei P9 so I will do a bit more investigating to see if I can get them working again.

Sadly with the latest updates that are coming to Android background services are now being fazed out as they were being abused by people keeping wake lock on devices when it shouldn’t be.

1 Like

They all seem to be working again on my phone. :slight_smile:

1 Like

Thanks for sharing your feedback Carl. What version of the app do you have? Have you been testing it for several payment instances and do you have a Xiaomi Redmi 3S Prime or another Android?

I’ll be testing today again as I’m off on holiday soon! First time abroad with Monzo!

He has Huawei 09 so won’t be MIUI skin but it’s hope all the same!

1 Like

As mentioned in the post above I have a Huawei P9 (which also has built in finger print security for individual apps, but that’s a bit o/t). It seemed that for a couple of days I didn’t receive any notification whether it was a top up or purchase etc. Still working properly now.

After extensively testing the new version (1.6.5) the app is finally working on my Xiaomi Redmi Prime 3S! It took about 3 months but things are good on this side now!

1 Like

It was a bit hit and miss abroad but since coming back one of the last 2 app updates I can confirm my notifications are now instant on mobile data too!

Many thanks guys

I have the same issue as described here: notifications work for other apps, whitelisted monzo and Google play services, turned phone off and on again, no luck.
Latest version monzo app (monzo current account 2.0.0 alpha3)
On a Samsung S8+, nothing custom.

Any other ideas?

I have the same issue. Running Android 8.1 on a Google Pixel 2 XL. userdebug build, dev keys. Haven’t had any pushes for months. Happy to email in a bugreport.

@eliotstock and @Kellanved - I’m really sorry about this.

Have you made sure Android is not battery optimising the app?

No big deal. Yes I have.

I think there might be a bug in android with these. I’ve tried everything and can’t get Slack or Skype to give push notifications anymore. My Monzo is working without changing any settings though.

Edit: I’m on Beta 1.18.1

2.0.0 alpha 3 is the obsolete current account app - that could well be your issue… it’s out of date.

You should be on monzo app 1.18.1

This solved my issue, thanks. I guess I deleted the wrong app when it converted to a current account.

I’m also on 2.0.0 alpha 3. The title of the app in Play Store is Monzo Current Account. How did I get left behind on an obsolete version? If I delete and reinstall from Play, what’s the correct app in Play?

Just the Monzo app, what was originally pre-paid. The account one was temporary for testing account features.

Is there a reason the other one hasn’t been removed from the store / had it’s name / description updated? It takes a few minutes to update it through the Google Play Developer console…

1 Like