✅ [Android] No notifications

No notifications coming through on my device even though settings are correct.
settings in monzo app

Settings on phone

Restart your device and retry?

Done, still not working. Not urgent I suppose, maybe it will sort out with new updates.

Try turning the notifications on and off again.

Sometimes this gets them going again.

Nope tried that first.

I’ve had this for weeks and tried the above to no avail. I guess at some stage I’ll uninstall the app but its annoying, not sure what triggered it. Before that the fingerprint auth turned itself off too (and I hasn’t added new prints to the phone)

Fingerprint Auth often became disabled when the app was updated, although recently it has continued to work for me throughout several upgrades.

What version of app are you running and are you on test flight (iOS) or beta (Android)?

thanks David, I suspected it was update related… Im on Android standard release version, currently 3.0.0

Tbh I’m as much interested in why the notifications just stopped than it being a massive issue. I work with apps (including notifications) for a living. I tried clearing the app cache. As these things go I imagine uninstall /re-install will resolve it. I thought I’d wait for the latest with the new UI. But I’m going to assume that won’t fix now either as I have the up to date release, just waiting on the UI rollout

Not many others appear to have reported it

A few users have previously reported loss of notifications (and sounds) and the usual ‘uninstall Monzo app, restart device, download/install Monzo App, run Monzo app & login’ has worked.

It’s not clear from the above reports that you’ve done this yet - I’d recommend doing it as it should work :crossed_fingers:

Could it be a battery optimisation thing?

Thanks to both of you for the suggestions. I’ve gone for the uninstall/reinstall and would be pretty sure that’ll do it but we’ll see.

I always like to know “why” in these instances but meh

@Rat_au_van battery was a good shout but I couldn’t see anything there that could be impacting

One other thing I did observe around this time which I’d forgotten was that I had to swipe/pull on the transactions screen to get it to update as well… but that had resolved itself. Definitely seems like there was some blockage perhaps on polling.

as expected a re-install solved


Good to hear all is now OK :smile:

Managed to get my friend to help me out, turned out I didn’t have enough memory for monzo to install fully.

1 Like


We’ve included a fix for the no notifications bug which will be rolling out in the next beta. Thanks for your patience this was a tricky one to track down.