[iOS] iOS 13 Beta 1 Hang


Hangs on launch with iOS 13 Beta 1. Reinstalled the app and can get to pressing the login link in the email after which it’ll keep hanging again till the watchdog kills it. I have the rest of the log if needed but I imagine it’s easy to reproduce.

Crash log:

{“app_name”:“Monzo”,“app_cohort”:“2|date=1559205000000&sf=143444&tid=67ee974d40d9928b07aacf5733acf65f6bc49d22888cc2aa7b78583277389e7b&ttype=e”,“app_version”:“2.50.0”,“timestamp”:“2019-06-03 22:11:53.06 +0100”,“slice_uuid”:“438b2c9d-0520-364a-baf0-76e70be0673a”,“adam_id”:1052238659,“build_version”:“530”,“bundleID”:“io.b2a.BankProd”,“share_with_app_devs”:true,“is_first_party”:false,“bug_type”:“109”,“os_version”:“iPhone OS 13.0 (17A5492t)”,“incident_id”:“6F99C525-32F2-4617-85F6-293F39BACAAB”,“is_beta”:true,“name”:“Monzo”}
Incident Identifier: 6F99C525-32F2-4617-85F6-293F39BACAAB
Beta Identifier: BBA95335-D244-4443-AA04-33AB902E9199
Hardware Model: iPhone11,6
Process: Monzo [406]
Path: /private/var/containers/Bundle/Application/4F3C9E3F-A1E1-42A6-9E6F-98EFC34BB1F7/Monzo.app/Monzo
Identifier: io.b2a.BankProd
Version: 530 (2.50.0)
AppStoreTools: 10E121a
AppVariant: 1:iPhone11,6:12.2
Beta: YES
Code Type: ARM-64 (Native)
Role: Non UI
Parent Process: launchd [1]
Coalition: io.b2a.BankProd [595]

Date/Time: 2019-06-03 22:11:52.6035 +0100
Launch Time: 2019-06-03 22:11:32.5669 +0100
OS Version: iPhone OS 13.0 (17A5492t)
Release Type: Beta
Baseband Version: 1.50.23
Report Version: 104

Exception Type: EXC_CRASH (SIGKILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Termination Reason: Namespace SPRINGBOARD, Code 0x8badf00d
Termination Description: SPRINGBOARD, scene-create watchdog transgression: application<io.b2a.BankProd>:406 exhausted real (wall clock) time allowance of 19.53 seconds | ProcessVisibility: Background | ProcessState: Running | WatchdogEvent: scene-create | WatchdogVisibility: Foreground | WatchdogCPUStatistics: ( | “Elapsed total CPU time (seconds): 81.700 (user 81.700, system 0.000), 68% CPU”, | “Elapsed application CPU time (seconds): 19.219, 16% CPU” | )
Triggered by Thread: 0

Thread 0 Crashed:
0 libsystem_kernel.dylib 0x00000001b7a4f5d0 0x1b7a2a000 + 153040
1 CoreServicesInternal 0x00000001ab5efe6c 0x1ab5de000 + 73324
2 CoreServicesInternal 0x00000001ab5edbe4 0x1ab5de000 + 64484
3 CoreFoundation 0x00000001b73ce540 0x1b72d3000 + 1029440
4 CoreFoundation 0x00000001b72dc524 0x1b72d3000 + 38180
5 Foundation 0x00000001b6f0c948 0x1b6ee0000 + 182600
6 libswiftFoundation.dylib 0x00000001082bc408 0x108214000 + 689160
7 Monzo 0x00000001054d35a8 0x1049e0000 + 11482536
8 Monzo 0x000000010580ed10 0x1049e0000 + 14871824
9 Monzo 0x0000000104ccd860 0x1049e0000 + 3070048
10 Monzo 0x0000000104ccdb7c 0x1049e0000 + 3070844
11 Monzo 0x0000000104ccddbc 0x1049e0000 + 3071420
12 Monzo 0x0000000104cc7550 0x1049e0000 + 3044688
13 Monzo 0x0000000104cc7200 0x1049e0000 + 3043840
14 UIKitCore 0x00000001bf661794 0x1be7de000 + 15218580
15 libobjc.A.dylib 0x00000001b791f248 0x1b791e000 + 4680
16 QuartzCore 0x00000001b9dd3df4 0x1b9c8f000 + 1330676
17 QuartzCore 0x00000001b9dd4104 0x1b9c8f000 + 1331460
18 UIKitCore 0x00000001bf64d4bc 0x1be7de000 + 15135932
19 Monzo 0x0000000104cc69d0 0x1049e0000 + 3041744
20 Monzo 0x0000000104ccc2d0 0x1049e0000 + 3064528
21 Monzo 0x0000000105000530 0x1049e0000 + 6423856
22 Monzo 0x000000010500143c 0x1049e0000 + 6427708
23 Monzo 0x0000000105000f9c 0x1049e0000 + 6426524
24 UIKitCore 0x00000001bf3b2168 0x1be7de000 + 12403048
25 UIKitCore 0x00000001bf3b265c 0x1be7de000 + 12404316
26 UIKitCore 0x00000001bf37f668 0x1be7de000 + 12195432
27 UIKitCore 0x00000001bf39c994 0x1be7de000 + 12315028
28 UIKitCore 0x00000001bf661794 0x1be7de000 + 15218580
29 libobjc.A.dylib 0x00000001b791f248 0x1b791e000 + 4680
30 QuartzCore 0x00000001b9dd3df4 0x1b9c8f000 + 1330676
31 QuartzCore 0x00000001b9dd4104 0x1b9c8f000 + 1331460
32 QuartzCore 0x00000001b9de7268 0x1b9c8f000 + 1409640
33 QuartzCore 0x00000001b9d3a5e0 0x1b9c8f000 + 701920
34 QuartzCore 0x00000001b9d65510 0x1b9c8f000 + 877840
35 UIKitCore 0x00000001bf1e822c 0x1be7de000 + 10527276
36 CoreFoundation 0x00000001b737f830 0x1b72d3000 + 706608
37 CoreFoundation 0x00000001b737efb4 0x1b72d3000 + 704436
38 CoreFoundation 0x00000001b7379fdc 0x1b72d3000 + 683996
39 CoreFoundation 0x00000001b7379874 0x1b72d3000 + 682100
40 GraphicsServices 0x00000001b655337c 0x1b6550000 + 13180
41 UIKitCore 0x00000001bf1cff0c 0x1be7de000 + 10428172
42 Monzo 0x00000001049e41b4 0x1049e0000 + 16820
43 libdyld.dylib 0x00000001b78e273c 0x1b78e1000 + 5948

I absolutely appreciate the need and usefulness for bug reporting, but this feels a little premature! It’s a dev release, it’s not meant for everyday users. Stuff is going to break!

Best thing to do in my opinion is let Monzo test their app internally, that’s what the Dev preview is designed for!


I doubt they are awake testing right now tbh but it’s also helpful us posting our findings in case they differ from what they do see.


Monzo will still need to support iOS 13 so any bug reporting will be helpful so that they can hit the ground running!

Edit: I can confirm the bug/issue.

Details to reproduce:
Install iOS 13.0 Developer Beta 1 then try to open the Monzo app.
iOS 13.0 (17A5492t)
iPhone X
App Version:
Version 2.25.0 (530)
Hangs and crashes on this screen at login.


True - but I also think they’ll have more than enough time to test thoroughly.


Its also useful for those of us who like playing with new stuff to know it will break our banking apps :wink:


I’ve had to install Monzo on an old iPod Touch until it is fixed and it actually looks okay :grin: .

Edit: Corrected Pad to Pod :laughing:

I’ve had to install an Android emulator on my Mac and install the app there until this is resolved

1 Like

I think you meant iPod Touch? Pretty sure all iPads are touch :stuck_out_tongue:

1 Like

Oops! :grin:

1 Like

Just updated to the latest version (2.50.0) and it’s still not working properly, although I believe the TestFlight version is 1 week ahead of the release anyway?

Anyone who is on the TestFlight able to confirm if the next version (Maybe 2.51.0) is working?

TestFlight is 2.50.0 atm

I’m running the latest TF build and having the crash issue. If Monzo’s release cadence is anything to go by, we’re expecting a build in a couple of days, so we’ll see if it comes built against Xcode 11

What’s the best way to get hold of the TestFlight builds? I assume it’s invite only but I never found the best place to sign up/register

I think in app chat is the only way nowadays. I signed up a couple of years ago through the forum

We’ll be fixing this but not immediately.

While we don’t block pre-release software as some larger banks might, running pre-release OSes is done entirely at your own risk.

Apple has made it clear that this year’s Beta 1 developer seed in particular has a lot of things broken and is not for use on your primary device. (I say this having lived through iOS 7 Beta 1 on a main device.) :sweat_smile:


Thank you for stating that you will be fixing this. It will be a shame that it isn’t sooner though.

I know the iOS Dev page points out the possible errors but I find it quite stable. I have to say Monzo are in the minority with financial apps that work in iOS 13 (based on what I have access to).

Financial apps that do not work with iOS 13.

  • Monzo
  • Smile
  • Coop Bank

Financial apps that do work with iOS 13.

  • Halifax Bank of Scotland (@tomsinclair confirms works.)
  • Lloyds (@tomsinclair and @harryru confirms works.)
  • HSBC (@walderston confirms works.)
  • First Direct (@walderston confirms works.)
  • Curve
  • Barclaycard
  • Freetrade
  • Atom
  • bunq
  • Coinbase
  • Coinbase Card
  • Jaja
  • Amex
  • MBNA
  • Virgin Money CC
  • N26
  • Paypal
  • Dozens
  • RBS
  • Barclays
  • Starling
  • Revolut
  • Monese
  • Tandem

Edit: Edited again!


I can confirm that Halifax and Lloyds Bank (maybe Bank of Scotland too) also do not launch on iOS 13

Edit: looks like the Lloyds branded apps (Lloyds, Halifax and BoS) do work, they crash on the first attempt but if you try again without force closing or restarting the device, they seem to work. @Chapuys you can update the list again! :smile:

1 Like

MBNA (uses Lloyds) crashed at first attempt to login then worked fine afterwards. Did you retry? I’ll add them for now.

Yeah, force closing the app and also a forced restart of the device, both apps still don’t launch. Not the same as the way Monzo seems to hang, it takes a few seconds and then closes completely

1 Like