IOS 14: can't log in / Magic link not working

I deleted the app to cure a problem with my feed not showing all transactions. Re-installed app and clicked on ‘log in’ and received the email with magic link, however the link just takes me back to the log in screen!
This has happened 4 times in a row so appears to be stuck in a loop and now can’t log in to Monzo app


Have you rebooted your phone?

No, but why would that stop the email link from going to log in screen every time?

Because sometimes software is odd. Just try it?


Ok trying now

Nope, still not working after reboot. Just stuck in a loop

Hmm. I’m stumped. Could it be that you’re clicking an old magic link? In which case delete them all and then retry and ensure you’re clicking the newest.

Failing that, you may have to email Monzo.

Thanks, I did that as there were a lot of magic links so I deleted old ones to make sure I was clicking on latest one!
I’ve just got off the phone from support, they couldn’t fix it either and have now escalated it and now got to wait for an email reply as can’t use chat obviously!
Not happy!

Just had a thought.
I am running beta iOS 14 so can anyone else tell me that is also running ios14 beta whether their magic link is working?

Exactly the same experience this morning so now locked out. I wonder if as on iOS 14 beta, that hasn’t updated since yesterday when Monzo login was fine but Monzo seems to require you to login every now and then so may be the first time that happened since iOS update.

Are you on the TestFlight or App Store version?

Test flight 3.47.0 (664)

Although I did try App store version first before TF version and both failed.

This is unlikely to work but if you are using a 3rd party email client , try copying the monzo Auth link and pasting it in a system app such as iMessage and then click on it from there.

This is happening to me too on same TF on iOS 14 latest PB

I logged out of Monzo to test this and I can no longer log in (on iOS 14 b6 and the latest testflight) so it isn’t isolated to your phone either.

You try and log in, select the magic link. It opens in Safari and asked to reopen Monzo and when it does it doesn’t move and stays at the Monzo login window.

Don’t logout and try it like me if you need immediate access to Monzo :crazy_face: .

Edit: I also tried deleting the testflight and using the iOS Store latest version and it doesn’t work.

Right, this is definitely related to a more recent iOS update.

I just installed the oldest Monzo testflight version available, under previous builds (3.36.0 (640)), and it logged in fine. I have not tested if a newer older build works.

I have then updated automatically to the latest again (3.47.0 (664)) and have stayed logged in.

Edit: As posted below by @DazF, the previous testflight build 3.46.0 (662) will work to log in.


Cheers for that info, so to give further update I can confirm I rolled back to 3.46 version and all works fine and I’m able to receive and log in through magic link as expected. So it would appear. That it is only latest version 3.47 that messes up magic link email.

1 Like

Possibly related @nexusmaniac ?

I’m having the same issue since this morning. Can’t log in at all :expressionless:

I’m on iOS 14 but not on TF for Monzo. It’s odd because nothing has been updated, so far as I know, it just logged me out randomly.

What’s the email for support? I’m not able to call at the moment.

1 Like