✅ [iOS] Can't send money RSA Error


(David Zilvys) #1

Hello so I got my new phone seemed like everything is fine with Monzo but when I go to pay someone it says RSA private or public key needed I will provide a screenshot.

Samsung Galaxy S8 plus


'Need RSA private or public key'
RSA fingerprint authentication when trying to make payment
Moving money issue
(Marcel Ruhf) #2

Have you tried disabling nd then re-enabling fingerprint support for payments?
To me it looks like an error related to the fingerprint confirmation prompt (which, if I’m not mistaken, is something OS-specific given that it looks the same across different mobile banking apps).


(Kolok) #3

As mentioned before try the fingerprint settings in the settings menu, if that doesn’t work message support one of the tech ppl will definitely get back to you


(David Zilvys) #4

So the issue was none of those. It happened to be that at the time of me trying to send money monzos sending payments was down so no matter what I tried it didn’t work. It is fixed now though that k you for all the advice :slight_smile:


(Richard Wright) #5

I have been trying to make payments for the past 24 hours on the below device, but whenever it asks for my fingerprint, it comes up with the below error. Some brief googling indicates a problem at Mastercard end, but I can’t find anyone else suffering from this.

Anyone have any ideas?

Android 8.0.0
Xperia XZ Premium
2.12.2


(Johnny Ellwood) #6

Can I ask if you are going through an AdBlocker or VPN?


#7

Not that you should have to, if you turn fingerprint validation off does it work okay with PIN entry?


(Richard Wright) #8

Yes, turned it off, and it works fine. I can use the sensor in Google play or my Rbs account fine, just not Monzo.

Oh, and no VPN / AD blocker


(Johnny Ellwood) #9

Are you on a public WiFi? If so can you access other HTTPS sites on your phones browser OK? Just ruling out the possibility of the app not being able to complete the secure handshake over SSL.


#10

Do you have a pin / passkey set on your phone, or have you changed it recently?


(Daniel Bolland) #11

I had this issue on my Samsung S9+ running oreo! I’ve contacted a staff member and reported this issue.

Try turning fingerprint off in Monzo settings then force close Monzo app and turn it back on in Monzo settings. that should fix it. that worked for me

hope that helps :+1:


(Richard Wright) #12

Nope, home WiFi, and it’s protected and everything else works fine (barclays / RBS).

PIN yes, but hasn’t been changed recently.

OK, I’ll give that a try.


(Kolok) #13

I’ve also had that issue, I can’t remember what fixed it but it was something simple, maybe turning off and on fingerprint authentication, or restarting the phone, I’ve seen this issue a few times on the forum.


(Jack) #14

This happened to me after I received a new debit card, to fix it I think I put through a transaction that required my PIN, then turn on fingerprint Auth again.


(Marc Dando) #15

Hi all,

Just wondered if anyone else has this issue and what it means exactly. First time it happened I contacted the in-app chat and I was advised to delete and then reinstall the Monzo app. This worked a treat at the time, but I seem to get the same message almost every time I try and transfer money to someone. And last night I had the same message when I tried to approve/authenticate an online payment. Deleting and then reinstalling the Monzo app continues to solve the issue, but it’s a bit of a pain to have to keep doing that really.

P.S. Ignore the frivolous Asda spending :sweat_smile:


(Mo) #16

I’ve not seen this on my Android, it says something like provide fingerprint to continue.

Have you tried resetting the biometrics in your phone settings?


(Marc Dando) #17

I do get the message about the fingerprint, but then I get the ‘RSA private or public key’ message after providing it. Do you really think I should reset that side of things? I don’t seem to have any issues accessing the app via fingerprint you see.


(Nathan Steer) #18

RSA keys are related to the encryption/decryption of data. This kind of error normally occurs when you have failed to get the cipher necessary to decrypt the data (within the code, not really anything the end user could do to fix it, as far as I’m aware).

Stack Overflow for reference: https://stackoverflow.com/questions/34265943/android-decryption-error


(Marc Dando) #19

You’ll have to forgive me, I’m not entirely sure what that means :sweat_smile:


(Nathan Steer) #20

Basically, the RSA key is used to take encrypted data (in this case, your finger print) and turn it into data that can actually be used by the app :slight_smile:

If, for whatever reason, the app fails to generate that key (through a process of certification with the data provider), then the data can’t be decrypted and you’ll see an error like the one you mentioned in your original post.