Bug? App crashes when completing a shared payment

I have a payment request from a friend but when I try to approve it I’m asked for fingerprint. After successfully reading finger the app just stops on the ‘complete transaction’ screen totally unresponsive. I close app and when reopen it the transaction hasn’t completed.

Have you tried deleting and reinstalling the app? Or rebooting the phone?

The app has just updated it’s self before trying this transaction. I’ll do the phone reboot

Phone restart didn’t work. And clear app cache hasn’t worked. Will uninstall app

Logging out of the app and back in again has worked but it’s reverted to pin rather than finger print

1 Like

Glad it’s sorted. Just switch your fingerprint authentication setting back on and all should be good :+1:

1 Like

Unfortunately it’s not sorted. It lasted about once. Now the only way to approve payments is by pin. The fingerprint authentication only works for logging in. If I try using it for approvals it’s like the the scanner accepts and the finger prompt goes away but monzo just sits there unresponsive.