Cannot send payments, freezes at last step

Hi, I tried going through the in app Help categories but couldn’t find a solution

I cannot send payments to peoples bank accounts, tried a few times.
The app freezes for a while then eventually lets me go back but does not complete the payment.
The final step is fingerprint to confirm payment, then nothing.
I’v tried it quite a few times, to different account and tried restarting phone etc, nothing fixed it.

Samsung S8
Android 9
App version 3.56.0

How can I fix this please?

Have you tried deleting and reinstalling the app?

1 Like

Also, not a long time fix admittedly, but you could try turning off biometrics in the settings and trying approving using your PIN

At least you would know that it is not an issue with your account

1 Like

I reinstalled the app, payments worked!
Then reactivated biometrics and it still works!

Thanks for the help, I appreciated the quick replies


If there’s something strange in the neighbourhood, call Ghostbusters

If there’s something strange in the Monzo app, delete and reinstall

i ain’t afraid of no ghost :ghost: