Initial Top Up Bug - Apple Pay


(Adam) #1

I have tried to top up the card initially multiple times with the apple pay button, it’s taken the money out of my account and the apple pay process says “payment not complete” and has not updated the app screen. Please advice what to do. I’ve done it 3 times so essentially I am missing £300 from account


( related to Monzo CEO, Investor in Monzo ) #2

have you tried the in app chat to talk with somebody that can solve this at Mondo rather that the community site ?


(Richard Dingwall ) #3

Hi @mintuz! Please contact us using the in-app chat and we’ll get this sorted out for you ASAP :slightly_smiling_face:


(Andrew Ross) #4

Have you upgraded your app to the latest version (1.5.1)?


(Pete Scarratt) #5

Tweeted them earlier about this. Used Apple Pay for my initial deposit which I was informed by the app that had failed (8am this morning). So I then used the debit card top up which worked.

Checked my bank earlier & I have 2x £100 pending payments.

Not an issue, but it could easily of been if I didn’t have funds to cover.

EDIT: This was using v1.5.1 as I updated yesterday.


(Adam) #6

The app was up to date and I couldn’t get access to the chat because I wasn’t signed in. Tweeted Mondo and this has since been resolved.


( related to Monzo CEO, Investor in Monzo ) #7

glad to hear its resolved

for future ref you could have also emailed them at help@getmondo.co.uk - I did at 10.55 pm on thursday evening and got a reply from Dillon at Mondo by 11.01 pm