Aargh google pay

AARGH! turns out google pay just rolled out SCA.

My wife goes to pay for shopping… instead of paying a box popped up asking for the ‘Google Pay Pin’. It’s not the Monzo pin, and the phone has no pin, so we were left scratching our heads trying to work out how to pay.

On top of that if you abort and try again the till locks out contactless but doesn’t tell you - 3 cards later, and supermarket security was starting to take an interest…

I think in the future I’ll pay with chip and pin as it’s easier…

I use Google Pay for pretty much all my purchases and haven’t had this.

Googling took me to this that says it is just for sending payments and it can be turned off:


That’s weird. I’ve just looked at my Google Pay settings page and I can’t see anywhere to set or re-set a PIN. Google isn’t much help either, could only find info on how to put a PIN on a Google account - unless that’s the same thing? Sentence removed because I see now that @Ordog found a link.

Can’t find anything on the internet about Google Pay changing anything for SCA. Makes me wonder, perhaps it’s a misconfigured terminal or something of the like?

It’s not that… the account has no PIN set, I checked.

It’s something else…

I’ve never seen it before, it must be new. I’m guessing it’s supposed to be the monzo pin but isn’t quite working right.

I pay for practically everything by Google Pay, so if it is an actual thing then I expect I’ll see it soon enough.

In the meantime, I should perhaps try and remember where in the house I left my physical Monzo card… :grimacing:


Which shop was this? Was the transaction over £30

I use gpay almost exclusively and I haven’t see this.

Yeah it’s a hassle fishing for cards unexpectedly then having to look up PINs etc. when you haven’t needed them for weeks…

I’m now forewarned to expect it, so less shock next time, just go straight to chip and pin.

I use Google pay a lot on both my Android phone and Android wear watch.

Very very occasionally I get promoted to check my device on the terminal after passing my device (watch or phone) over the reader. If I was using my watch, the watch screen asks me to enter my watch screen pattern and then to try again after which it works immediately, same process if it was my phone except I enter my phone unlock pattern and then it tells me to pass the phone over the terminal again. It’s done it with my VISA card as well as my Monzo MasterCard and way way before strong customer authentication came in. I think it’s a standard Google pay additional security prompt. I think it definitely does this when its over the £30 limit as I can definitely remember paying for a big Morrisons shop and paying by Google pay and got the additional prompt but transaction went through with no issue after I followed the instructions on my phone.

Like I say it’s only happened to me a handful of times but was clearly explained via the on screen prompt o. Either my watch or phone.

The prompt was just ‘Enter Google Pay PIN’ which I don’t consider a clear explanation at all… I’m still not sure what a ‘Google Pay PIN’ actually is…

If it had been the normal phone authentication screen it wouldn’t have been an issue as presumably fingerprint would have worked.

Was the transaction for more or less than £30?

Does your phone have a fingerprint reader?

Only £21…

Yes, and the phone was unlocked using it (although I found out after investigation that the fingerprint confirmation was disabled* in the monzo app that shouldn’t interact with google pay in any meaningful way).

I’ll jump in here and say that fingerprint check on app open was disabled again for me too after the last update. This happened to me several months ago too.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.