Unable to get statement from pot

I have been getting a ‘something went wrong’ error every time I try to get a pdf statement from my instant access savings pot (opened on 27th may).
I am able to get a statement from an archived pot and I have tried reinstalling the Monzo app and restarting my phone.
If anyone has any ideas it would be greatly appreciated.

Hi @toastie & welcome :wave:

I’ve just tried downloading PDF statements for my IASP (for July, Last 3 months & All time) and all worked OK - using an Android device.

What device & :monzo: app version are you using?

1 Like

Hmm… Odd.
I’m using a one plus Nord and have Monzo app version 5.34.0

Maybe I’ll try it on my wife’s phone when I get home this evening.

I just set up my work phone (iPhone 12) and after getting through security stuff on the app it downloads statements fine!!! Very happy that i can get the information to my mortgage broker but i am not too sure why it didn’t work on my OnePlus. I think it may have been something to do with the privacy and security settings which i then had to set up on the iPhone.
Thanks for the support.


Hi, good morning.
I have problem how transfer my money from paypal to Monzo to do declined for paypal
I any one have idea to help me
I appreciate that help