[Android] Crash when creating an Easy Access Savings pot ISA


I just made my account with Monzo, which seems to have gone fine and everything is now confirmed. However, I’ve tried making an easy access savings pot, and whenever I get to the agreement stage of the application the app crashes, if I do it enough times the phone itself tells me that the app is crashing a lot.

So far I’ve tried making an Easy Access Pot with a different provider (the OakNorth Easy Access ISA), which did let me put in my NI number but then crashed again on the agreement, leaving the round up option on and off, using a premade pot name and one I wrote myself, and using and not using a photo. All of the above seem to crash when I get to the agreement stage.

Any help would be great, thanks!

Hello :wave:

I wonder if this is related to the new layout? Do you know if you are on the new navigation or not?

If you’re not sure - does your app look like this?


Sorry it’s been a week but I’ve only just had time to come back to this.

I’m pretty sure I’m on the new layout. As I was getting the issue on the stock version of the app I opted into the beta program in the hopes it would have a fix - no dice.

This isn’t a deal-breaker for me as I’m mainly interested in Monzo for the foreign currency benefits when I’m travelling, but it is something I’d like to use in the long term.

I’ve recently tried spam clicking the general area of the approve button that appears with the contract document but that doesn’t work either. I have also updated to what I think is the latest version of the beta too, with no improvement.

It’s definitely crashing on the contract screen, though it does appear to be loading in at least some of the contract.

Edit: here is a video of what happens


I think it’s failing because you aren’t putting the minimum amount in to open a full savings pot, which iirc is £500.

I guess it’s just not loading the error message (but is erroring) going through to contract then just breaking.

Edit: just seen some of those have a £10 minimum deposit??? When did that happen? The plot thickens!

Double Edit: I don’t have any with a £10 minimum deposit. I wonder if you’re in an experiment that isn’t working. It might be best to talk to chat through the app.

P.S it looks like you’re selecting a easy access savings pot and not an ISA on your screen recording.

1 Like

I did try talking to chat when I first encountered this bug, who suggested I uninstall and reinstall the app, which unfortunately didn’t work - really I should have gone back to them and tried to work things out further, though the bot did say to take it to the forum as well.

Interesting how you don’t have access to the £10 pots. I’ve had access to them from basically the minute I opened the account, so I guess it’s an account level feature, if it is an experiment.

I’ll see if I can flag it up for help!

1 Like


Could you try upgrading Chrome on your device?



I’m currently on the latest version of Chrome for Android. I also went ahead and downloaded the beta versions but that hasn’t had any effect.



Thanks for checking, could you let me know which version of Android and what device you’re using?