POS terminal crashes, apparently only with Monzo card


(Nick Perry) #1

There are two retailers around Bank, London where the Monzo card appears to crash the POS terminal when used contactless. “Patty & Bun” and “Piada”. In both cases the person behind the counter actually expected it when they realised it was the Monzo card (or “the pinkie, always the pinkie!”). In the latter case the reboot caused the card to work second time, contactless. In the former case they asked to try chip and pin and that’s OK.

At Piada it was an Ingenico IPP350 terminal owned by Barclaycard. At PAtty & Bun it was also an Ingenico, but not sure what model.


(Rika Raybould) #2

I’m not crazy then!

Same terminal vendor too, IPP350 and also IPP320s, mostly at discount retailers and independent stores. I’ve seen the crash consistently across Monzo and Revolut contactless cards as well as Wirecard’s Boon card in Apple Pay. All of these are MasterCard prepaid. Not all terminals of that type do it though, it may be software version or configuration specific.


#3

Had problems with another banks card not working on contactless but only chip and pin…and it was on same make of terminal you mention!


#4

I wonder if those retailers will get extra customers tomorrow from people seeing if their card will crash it. How long does it take to come back online after the crash? I’ve not seen a recent credit card terminal boot up.


(Tom ) #5

Ha. Had this in Franco Manca. They had never seen it happen before. Completely bricked it even after a restart. Had to find a second device to take payment.


#6

It worked in the Bermondsey Street Franco Manca a couple of weeks ago. So it looks like they don’t have the issue with every terminal (or a more recent update has introduced the bug)


(Robi Gyorky) #7

I had this happen again today so doesn’t look like it’s been fixed yet.


(Nick Perry) #8

Both the shops I originally reported this add are now working correctly with the same physical terminals so it looks like a software/firmware fix has fixed it for them at least.


#9

I guess some banks or payment networks are slower releasing fixes. I’d guess some of the networks brand thier firmware