Please insert your phone…

Here’s what happened yesterday, on a train:

Ordered a tea from the trolley, the server had a portable card machine with contactless. I only had my iPhone. After tapping, the card reader required me to insert my card, which I obviously couldn’t do, and neither could I use another card as I only have one card in Pay.

The server looked a bit blank, and didn’t really know what to do. He said again, “it’s telling you to insert your card” and I had to say to him, “how do you think I’m going to do that with a phone?”

In the end he gave it to me for free.

Is this a case of the card reader being incorrectly configured, or potentially trying to make an offline transaction? I thought Wallet Pay transactions were always authorised.

Any thoughts? Where’s @Rika when you need them? Ha!

7 Likes

I’ve never had that with Apple Pay… didn’t realise it could happen.

4 Likes

All the years I’ve had apple pay. It has never asked me to insert my card.

This is strange.

Only thing I can think of…. Is there wasn’t any signal in order to check if Apple Pay was genuine or not? Maybe inserting a card has a way of checking/storing card details until signal is gained and it tries again when signal is back?

5 Likes

My worst fear! :scream:

I only mentioned this the other day on here as the reason why I darent leave without my wallet. I hadn’t actually heard it happen to anyone though!

6 Likes

I would just ask them to cancel the transaction and try again. It’s not Apple Pay asking; from what I understand it’s the issuing bank asking for the PIN?

3 Likes

If it’s the bank issuing the pin request. Why doesn’t this happen to people more often when using Applepay?

:point_up: This.

It’s the same on planes, where they take payment but it isn’t charged until the data from the terminals is downloaded at the destination (on the ground) - they store the transactions locally due to lack of connection. I remember having to insert my card after using my phone with a contactless terminal on a flight to Greece, it must be a belt-and-braces procedure to ensure the actual card was presented when the purchase took place.

4 Likes

I thought this was the case.

Contactless/applepay is basically a touch and go scenario. If they regain signal and the payment fails. The train company lose out on payment.

If the card was present and used via pin. The train company can temp save the details and retry later on. Also it tells the bank that the PIN number was used so someone was present. Where as tap and go, there’s no real proof who made the payment (my theory anyway)

Thanks all. I’m surprised the machine can’t tell the difference between a card being used contactless-ly, and a Wallet Pay transaction.

He kinda had to give me the tea free because I’d already slurped it by the time he caught up with the trolley and put through the transaction. I didn’t think to ask him to cancel and put it through again. Cost of a teabag? A fraction of a penny.

2 Likes

It’s an incorrectly configured terminal from the sounds of it. If it can’t perform an online transaction it can be configured to fail or failback to offline. This then depends on if your bank has authorised offline transactions on your card/digital wallet token.

But as others have suggested. Cancel the transaction and try again should work if it goes back online.

When you touch your phone it will share if it’s MasterCard or visa, credit/debit, of it allows offline transactions (and up to how much). It can also share authorisation data. You will see on some receipts it says “cardholder device verified” or similar.

Banks can then apply limits per transaction, per time period. As can merchants/merchant acquirers.

3 Likes

I was in Tesco the other day, used my card for contactless… it said “please insert card” and I got the notification telling me to use Chip and Pin. I just used Apple Pay instead and it worked.

Sounds like a store/terminal issue rather than Monzo tbh

2 Likes

Yes but it’s a thing to periodically require you to put your card in after several contactless transactions, for security. That terminal was behaving correctly.

1 Like

That behaviour is correct. When you spend a total of £100 via contactless using your card you have to authenticate by inserting your card.

Google / Apple pay doesn’t have this limit.

2 Likes

As others have said, there nothing wrong with the terminal in your case. Here’s aMonzo blog post about the feature:

As you say, using Apple pay (or Google pay) will get around the issue. I’ve scarcely used my actual card for years now because it’s easier to just use my phone instead.

4 Likes

This is exactly what happens. Whenever I’ve paid for something on a ferry or plane, the transaction goes through when you get to the destination and the terminal can connect

1 Like

He’s used Apple Pay though so it is a terminal issue because it should not be asking for chip and pin with mobile payments

4 Likes

Yes, I used Apple Pay so wasn’t able to insert anything. You used your card for contactless, so were able to insert that when asked in the supermarket.

I was replying to your reply and your reply only, not to the OP.

3 Likes

I had that in Asda once… never worked out what it was. Google pay contactless, and it came up with a pin prompt but it didn’t call it a pin, something else. Tried the phone pin and the card pin, nada… had to pay with a different account.

I think sometimes these termnials just have a mind of their own.

Were you watching something on your phone @j06 or had your phone unlocked for a long time before paying?

I’ve had it in the past where I’ve for example been using my phone as a satnav, gone into a petrol station and then tried to pay with Google Pay, but when I put my phone near the reader it asks for my fingerprint before it lets me attempt to pay again.
I can’t remember exactly what the reader does - I think it says something along the lines of ‘check device’

I imagine an incorrectly configured terminal would ask you to insert your card and enter your PIN at this point.

To give this a little extra background, you don’t need to be holding the fingerprint scanner whilst you’re paying with Google Pay, as long as you’ve recently unlocked your device, it will work (it also works from the lock screen without unlocking, but that’s another story for another day).

1 Like