New sign up - app crashes on multiple devices

Hi Folks
Just signed up for Monzo and went through verification.
I now cannot sign in - have tried using two different Android devices.

Symptoms are when I first launch app, I get the sign in screen. Enter email address, then click the link in the email sent to launch the app. When I do this it fails with “Sorry, please use the latest email sent” type error and from then on, every time I launch the app it crashes after a brief splash screen.

Have 100% repro on a Samsung S8+ and a Xiaomi A1 both on Android Pie.

Are there any android screen overlay apps or similar that might cause this? Anyone seen this? It makes Monzo entirely useless to me - the phone support just suggested reinstalling which I’ve already done as well as cleared cache etc.

My guess would be that because you keep trying you’re not clicking the latest email link. If one was a bit slow at coming through you might be behind the curve.

I’d suggest deleting all Monzo emails, restart your phone and try again :slight_smile:

Oh and make sure you’re using the email account you signed up with too.


definitely using the latest email, restarting etc. 100% repro on both devices. Have got support to log me out of all sessions, uninstalled, reinstalled and still a problem.
Waiting on to come back to me as phone support don’t have any more ideas…

It sounds very strange :confused:

Can you log in here:

Just want to eliminate any credential issues or something.

Yes, can log in fine there.

That’s one positive at least, just trying to narrow it down :sweat_smile:

Did you log into on your phone or PC and I assume the magic link worked? - can log in from PC or from phone browser just fine.
The app itself - when it’s freshly installed it will allow me to enter email address then waits for confirmation, as soon as I go past this point it instantly force closes and then each subsequent launch force closes again.

Have repro on two devices. I really don’t want to sign up for an account with Resolut instead, as all my colleagues were raving about Monzo, but this is pretty depressing as a first-run experience :frowning:

My phones aren’t rooted, I do have some apps like Cerberus and Lastpass which have screen overlay permissions, although removing these didn’t seem to help. Any restrictions I should be aware of?

So we’ve ruled out a bunch of things regarding credentials and stuff. You can log in elsewhere, so it is just something unique about your phone setup.

I have an S8+ and Lastpass, so I was going to ask if you might have some security on there that is blocking the magic link from doing it’s “magic”. Are you able to disable Cerberus temporarily to see if that is the cause?

Your phone is up-to-date with the latest OS I assume?

Yep, running latest Android Pie, as is the Mi A1 running Android One.
I have exactly the same problem on both devices however.
I’ve uninstalled Cerberus, disabled LP and same problem.

I can reproduce exactly the same issue on both phones. Whilst on phone to support I had them log me out of all sessions to see if that helped and unfortunately it doesn’t.

Not sure where to go with this now…!

Could you have freaked it out by trying to get in on several devices? Although granted not sure how to fix that if it has or even if it could.

Maybe try logging out of your email on all devices and going back in with a fresh magic link? Seems there’s something going wrong between the magic link and the app.

I thought of that, so I had support log me out of all devices which didn’t help.
At all times I can log in via
I’m definitely using the latest email links.

Feels like a bug in the app, but if it were I’m sure I wouldn’t be the only person seeing it, unless they pushed a bad update in the store recently, which seems unlikely…

I’ll report back if come back with a fix - in the meantime any suggestions appreciated!

Exact same problem on my Xiaomi A2 Lite phone (running on the latest Android One version).

interesting. Have you had it working or did this fail from day one? When did you start seeing the problem?

Have also had this occurring with an S9+. Login generates the email, clicking the link works fine, takes me to the splash screen and the app just quits immediately. Doesn’t look like it’s crashing but it just seems to be quitting.

Have uninstalled and reinstalled.

I was just trying to join Monzo and apply for a card. The application went through successfully, all details were uploaded but then after that it doesn’t look good. :stuck_out_tongue_winking_eye:

You could try signing up to the beta channel of the app, delete all Magic Links and see whether this is better?

Sorry, this thread is going to be a mess, replies appearing always at the bottom instead of the post that you clicked “Reply” on.

If you reply to any message apart from the one before, the profile pic of the person you’re replying to appears in the top right of your reply. Makes it a bit easier to keep track of who is replying to what

There’s probably a way to explain that in better English but my caffeine levels are critically low

Have also had to unfortunately create an account on the forum to report the exact same issue.

Have restarted phone multiple times, reinstalled app multiple times, used multiple email apps to open the magic link, and can log into Monzo web. Phone is OnePlus 7 Pro. Stock Android (no roms etc) and no interfering apps either.

Not the best guys.

I just moved to the UK from Canada and will be staying here for the long term.

I installed the app on my phone, and when I go to register, I am unable to. I enter my gmail, I receive the email, I click the “Log in to Monzo” button, and it brings me to the same page, asking me to enter my email address and send another magic link. This loops forever, I can’t proceed to make an account.

How do I fix this?