Monzo App Won’t Load

Issue: The App won’t load.

Details to reproduce: Tap on the app icon to launch the app, perhaps after restarting your phone (given no one else is reporting, I suspect it’s rare and won’t be that simple to reproduce)
OS: iOS 15.1
Device: iPhone 12 Pro
App Version: 4.8.0


The app has been stuck on this screen whenever I try launching it. If I wait long enough, a loading wheel appears under the Monzo logo.

I’ve tried reinstalling the app, doesn’t fix it. I’ve tried restarting the phone, restarting the app, and force restarting the phone to no avail.

This happened pretty much immediately after I updated the app to version 4.8.0 and had rebooted my phone.

Any further troubleshooting tips would be appreciated. Push notifications are still coming through. I need to get into it today in order to withdraw money from my PayPal pot to replenish my funds from paying my PayPal Credit bill yesterday, else I’ll be charged overdraft fees.

Edit: launching the app from a notification seems to get me into it as a workaround, so I’m now in and have withdrawn funds from PayPal Credit pot, so that issue has been averted.

If I quit the app though and try launching it from the app icon, I get stuck on that screen again. Sending myself more money and tapping on the notification gets me back into the app. If I don’t quit the app, I’ll retain access. How weird.

Edit 2: okay, so this isn’t the fix I thought it was. It might look like I’m in the app, and able to do things but nothing is loading or updating. The withdrawal from my pot isn’t showing up on the feed, and my balance is still negative. The transfers I made from Chase to get in aren’t there either.

Can’t replicate

I did have an issue this morning when I tapped on a credit report notification and it gave me an error message about an access token problem. But dismissed that and it was fine

1 Like

Thanks for trying!

The more I play with it, the more it seems like connection troubles. The app can’t talk to the server, or is very slow in doing so.

It has intermittently worked a few times now, enough to get the pot transfers sorted and show up on my feed and for my account balance to update.

Hopefully something on the server end that will just resolve itself at some point. I’ll report back if/when it starts working properly again.

This happened to me recently too. Pot went down, balance didn’t go up. Took a minute or two to catch up.

But same phone/same versions as you and all working fine for me today.

1 Like

Have you tried a different WiFi network, or using mobile data? You could also try resetting network settings…

1 Like

Aside resetting network settings (which is annoying, so would rather avoid) I’ve tried cellular, disabling iCloud relay (though conflicting information as to whether apps go through the relay anyway), I’ve tried routing through my various VPN clusters around the country, and even turning off IPv6.

To update on this, the app still won’t load. I’ve tried deleting and reinstalling a number of times now. Tried using the TestFlight version though it is the same build as on the App Store.

I’ve tried resetting network settings, broke iCloud Keychain and handoff in the process. No fix.

I’ve sent an email to Monzo, will update if/when they get back to me or the app starts working again. I suspect it’s going to need an update to fix itself though. But this is a pretty bad bug for app only bank!

Not able to reproduce this here, are you on Testflight? Can you download a previous version of the app, if it’s the latest version causing you issues?

1 Like

I was on the App Store version initially when the issue started. When uninstalling the app earlier I tried installing the testflight build instead of from the App Store, hoping that would fix it. It didn’t so I uninstalled and have the App Store version installed again. :pensive:

I’ll try to install an earlier build from TestFlight and see if that works! Thanks for the suggestion!

Edit: didn’t work. I’m gonna do some monitoring at the network level to see if there’s any indication there. It doesn’t feel like the app is even trying to phone home unless I tap on a notification.

Okay, so I’ve run several tests with launching the app whilst MITM myself. The app is trying to phone home!

These are all the domains it contacts:

Status page responds OK. Status code 200. All good there besides the favicon returning a 404. May wanna fix that Monzo. Easy to do!

It made an alarmingly high 81 requests to internal-api, which is where the server appears to be blocking requests. That could just be Monzo recognising what I’m doing and being smart enough to block it, but given the result is the same, the app not loading, I suspect for some reason, the server is denying my app’s requests to connect.

May have to wait for Monzo to reply to my email on this one and get things escalated. Nothing more I can do on my end if the issues are server side.

My android phone hit around 15 times successfully on app launch after a cache clear , so assuming multiple retries your 81 doesn’t seem out of the ordinary , obviously the error response is.

Can you browse to that URL from your phone?

1 Like

Would be if they all returned OK!

Yep, it loads just fine in Safari.

1 Like

Can you see the headers or responses?

1 Like

I don’t really have anything useful, I’m just entertained by this issue.

Since others aren’t seeing this issue , are you using dpi/SSL inspection or forcing http upgrade maybe .

1 Like

I can see the headers, not the response of the error. Successful connections I can see both. Here’s the request and raw headers:

SSL Inspection yes, only way to capture this stuff concretely on iOS to my knowledge. SSL Inspection is only a variable when the local MITM server is active on my device, which is only enabled for these tests. When it’s off there’s no DPI or packet manipulation of any kind either on my device or within my network.

I don’t see why this would be an issue anyway. I’ve never debugged on my personal phone before, but out of interest, tested a bunch of other banking apps to see what they spit out and no issues there.

I can breakout my MacBook later today and take a deeper dive without the need for SSL inspection. See what sort of results that kicks up, but I suspect the same.

The thing that’s got me stumped is the 999 error response only coming when the Monzo app tries to establish a connection. I wonder what’s going on inside the app.

Glad it’s brought someone some entertainment! :joy:

1 Like

Sometimes SSL inspection can cause issues when there’s cert pinning going on, but if you’re getting the same errors with inspection off then it’s probably not it.

I guess the only other things to check is another iPhone and the webui, to see if something is blocking your account specifically, although 999 indicates something else as it should be 403.

1 Like

This works!

And so does this, or on an iPad anyway! Whatever the issue is I do think it’s isolated to that particular phone, perhaps triggered by a very specific set of circumstances, making it hard, if not impossible to replicate. Can test on a dev phone later today to double check, but I suspect it’ll work like it does on the iPad.

Not a clue what I’ve done to break it here, or if anything extra happened between updating the app and rebooting my phone, but something went very wrong.

1 Like

Hopefully the right devs get on it and can check their end.

Definitely sounds like the request or response is getting malformed.

Or it’s some fancy AWS or third party security tool that’s fingerprinted your phone and blocking requests :man_shrugging:

Last but not least, when you reinstall the app make sure to do a fresh one not an iCloud restore, I’m not sure exactly what that means as I’m android but I’ve seen it mentioned.

1 Like

Thanks! Really appreciate your input!

I’ll report back with updates!

1 Like

Brief update.

No reply from Monzo yet. I’m able to log in and use the app on a dev iphone just fine, and that’s got root certificates installed which some apps take a disliking too when those profiles are enabled. Turns out have graphs and the flex virtual card invite as well, so that’s annoying!

Still can’t get in on my personal phone, so will make do with iPad for now.

I also can consistently get past the initial splash screen now and see what I presume is a cached version of my feed. Constantly says refreshing at the top and things like chat won’t load.

1 Like