Mondo app constantly logging out


(Ross) #1

Does anyone else have issues with the app always logging you out??


Constantly being signed out of mobile app?
#2

https://mondo.statuspage.io/

The mondo app is down at the moment.


(Ross) #3

Had this issue for a while.


(Caleb Wong) #4

From time to time it will log me out too! Maybe once a week or less.


(Rob Schlitt) #5

From the time I initially joined the queue (March) all the way through to the beginning of this month (August) it never logged me out once. But in the past week it has logged me out twice. :thinking:


(Tristan Thomas) #6

Thanks guys! Please keep these reports coming :slight_smile: @andys, @jgarnham and @james are trying to track down why this happens but if you can reliably reproduce it or have any other pointers, that’d be great!


(Ross) #7

@tristan this now seems to be happening on a daily basis


(Rika Raybould) #8

Open question: When you get logged out, what network are you connected to?

Interestingly, I’ve only seen it happen to me when I am on public WiFi that has some kind of HTTPS interception or redirection. Sadly, I don’t have the equipment or tools to test that here on holiday. :sunglasses:


(Ross) #9

It seems to happen no matter whether on wifi or 3/4g.


(Jason Yau) #10

same happens to me after i unlock with fingerprint. I get an invalid login token message and have to log in again, I use email - easilydomail not gmail or the native client.


#11

I have been logged out the last three times the app was updated. When I reported it on Twitter, I was asked to DM details but got no reply.


(Christopher J. Sladdin) #12

Have had this issue countless times in recent weeks as well. No idea what steps I’m taking to make it happen though.


(Josh) #13

Thanks all for the feedback! We’re looking into this at the moment and as @RichardR alluded to we think it’s related to the internet connection at certain times and certain related requests timing out. We’ll keep you updated and let you know when we have a fix out :slightly_smiling_face:


(Ross) #14

@jgarnham is there any updates on this yet. Was logged out again today. Still no ideas on what may be causing it


#15

I’ve been getting contually logged out since last night (Saturday). Starting become a pain now and has only happened since I’ve upgraded to the new Monzo TestFlight version. Any ideas?


(Rika Raybould) #17

As @-removed- said, there is a known issue with the Today Widget in the current TestFlight build.

For now, either return to the App Store version for the next few days or remove the widget.


#18

In addition, trying to log back in via email (airmail) has resulted in total lockups of the phone. Three in the last hour - I’ve had to reboot each time. :confounded:

Managed to remove the widget though, so let’s hope that sorts it!


(Ross) #19

Turned widget off. Still having issues with the app logging out


(Rika Raybould) #20

@JDub The lockups I’m investigating. I believe they might be an iOS bug as I’ve seen other apps causing this when using app deep links (and remember that Apple has had almost identical issues in the past). Are you using the current iOS 10 beta? I haven’t been able to reproduce it on iOS 9.

The lockups do resolve themselves after maybe 2–3 minutes when a watchdog restarts the offending processes and throws you back to the lock screen. Forced restarts are quicker though. :smiley:

@ross_o The widget related logout issue only affects the current TestFlight build.


(Rika Raybould) #22

Interesting, I’ll take another shot with my iOS 9 device tonight. The problem I’m having tracking this particular issue is that when it freezes, I lose all debugging connections with my main phone. Makes it very difficult to file a good bug report. :sob:

Update: I think I finally got it. iOS wasn’t happy with the app name changing from Mondo to Monzo. The other app I had issues with changed not the name but an identifier. From what I’m able to piece together from before the log cuts, iOS was still trying to launch Mondo as it was still named that in the iOS deep linking URL cache and hanging as even the binary name had been changed to Monzo. The iOS 9 device I was using had never seen the app as Mondo so was coming to Monzo from a clean state and did not have this issue. On my main iOS 10 phone, the issue was resolved after an app reinstall and phone reboot with two logins that redirected from getmondo.co.uk to monzo.com to the mondo:// URL before iOS rebuilt the deep linking cache and knew to send getmondo.co.uk/-magic-auth URLs straight to the app without bouncing through Safari.