Missing items from transaction history

Im looking for a past transaction that happened in October 2019 and I’ve just noticed all transactions from the end of September 2019 to end of November 2019 are missing.

Is anyone else missing items in this date range?

I have tried uninstalling the app and re-downloading, to no luck, does anyone else know what else I can try ?

EDIT: Ignore what I have to say on exporting; see the reply from @davidwalton below.
Have left the post to preserve the threading, and the last paragraph on things to try with the app still stands, at least (assuming no-one comes along to correct me on that too :sweat_smile:)

Try exporting your transaction history:

Make sure you in the current account view, and tap the pie chart at the top of the screen.

Scroll down past all the spending categories and pots, and at the very bottom you will see “Export & Bank Statements”

Select ‘All time’ for the period, and you can choose to have the export in PDF, CSV or QIF format.

That should get you the transactions you’re missing, at the least.

As for making them appear in the app - did you restart your phone after uninstalling and before re-downloading? If not, it might be a caching error of some form, and the uninstall didn’t remove the duff cache bits. Try going into your phone settings for applications and clearing both cache and storage. If that doesn’t work try doing that, then uninstalling, then restarting your phone before you reinstall.

Alternatively, in the :monzo: app, when you are in ‘Home’, drag down the feed to reveal the blue icons under the card.

Tap on ‘Account’ and then look for ‘Statement history’ and tap on it.
Select the date range you want to view and export - the choices are PDF, CSV or QIF - PDF will do. Once downloaded, open the file to view the statement.

Oh, wow. Hadn’t noticed that one, and that’s probably a better way to find the information the OP needs! I’ll edit my reply.

1 Like

We still need to find out why the ‘gap’ is in the transaction feed though.

There’s a few reports of this, with suggestions to try, but no posted ‘yes, that worked!’ results - so to start go through this thread:


Yeah, my last paragraph did offer advice regarding rebooting as part of the uninstall/reinstall, and clearing cache and storage. Hopefully OP will come back and update if any of these things worked.

1 Like

I thought this bug was fixed.

I’ll do my best to remember to flag it when I’m back at work on Saturday night :pray:t3:

1 Like

Good point, we haven’t established which app version is being used.

@braddders - what is the version of the Monzo app you are using? And which device are you using?