Logging out/Logging in


#1

Hi there,

I used to have the prepay card, I now have the CA. I have noticed that when I quit the app now, it doesn’t prompt me for fingerprint recognition (I do have it enabled) and just put me straight into my account. The only way round this is to “force close” the app and I am then prompted for fingerprint recognition the next time I open the app. This didn’t happen when on the prepay app, I alway got prompted for fingerprint recognition. Any ideas?

Thanks

Adrian


#2

This option is in account -> settings -> require Touch ID


#3

I know, that’s why I am telling you. I have it enabled and if you just close the app it doesn’t require it when you reselect it. It only works if you “force close” the app by double tap on the home button and swipe up on the app.

When it was prepay, it worked in all situations, even a soft close on the app

Hope that helps


#4

I just did that, opened app, closed it (did not swipe it away) and when I opened again it asked for my Touch ID.

Might be your phone / OS version? Raise a support call


#5

Have you tried switching it off in the app, closing the app, then reopening and enabling it again?

This did fix it for me once before.


#6

I have tried that, didn’t work.
I also uninstalled the app, rebooted my phone, reinstalled the app and it still doesn’t work.

Now, without banging a drum here, it used to work seamlessly so it would appear that the regression testing on this latest release was not comprehensive enough.

I have also noticed that if I select the log out option in the menu, the next time I open the app I have to do a full log in using the email and subsequent link. This also doesn’t seem that intuitive if you have Touch ID enabled.

So briefly, a few usability issues with the latest version of the app. Obviously I have discovered a workaround with the “force close” but it would work better than having to do that.


(MikeF) #7

It may not seem intuitive, but that has always been the impact of the Monzo log out. It logs your device out of your account entirely.


(Jolin) #8

It’s worth sending a message to in-app support so they can look into this for you. Having to force quit every time you leave the Monzo app is pretty irritating, and maybe there’s a solution they can suggest. Or they can file a bug internally.


#9

If I enable ‘Require Touch ID to unlock app’, I expect the app to ask for Touch ID each time I open the app. However, v1.9.21 357 only requests Touch ID when you open the app for the very first time. Here is a list of scenarios where I’d expect to be prompted:

  • Launching the app from a fresh boot (this currently works)
  • Force quitting the app and opening again (this works too)
  • After using app switching
  • Locking then unlocking the screen
  • Pressing the home button and reopening

Additionally, I find the description confusing:

Touch ID restricts access to Monzo, but does not encrypt your data when the app is closed.

Why is my data not encrypted? While I don’t particularly care that someone can see I bought some petrol, I would rather my data be encrypted at all times when I am not using the app.


(knows someone who knows Tom quite well) #10

On an iPhone running any modern version of iOS, your data is encrypted at all times.


#11

Indeed, so why was that wording chosen?


(knows someone who knows Tom quite well) #12

Good question


(Jolin) #13

(As long as you have some sort of passcode set. Which is a requirement for using TouchID with Monzo anyway.)


(knows someone who knows Tom quite well) #14

I truly hope there are no monzo users without passcodes on their phones!