Known issues / bugs 🐛🐜🐞

Couldn’t get mine to work contactless in the tube yesterday despite activating it earlier with the a PIN transaction…

I’m not sure if it’s been mentioned before, but contactless does not work in superdrug. However, chip and pin does work.

Was declined at The Lowry, Salford, car park, not sure what system they were using, but it wasn’t accepted and I had to resort to cash (yuck) :slight_smile:

I’ve had my card declined in some places recently, both annoyingly after the person has said that card is awesome, I’ve sold them on Mondo then I have to use a different card.

  1. The Kronwell hotel in Romania, worked in the bar, worked in the restaurant, worked at petrol stations and every other place but…not at reception checking out. Had to revert to my Halifax credit card :frowning:

  2. A little cafe in Harrogate

However very impressed with card use abroad. Topping up in English, spending what I want, coming home not having to get any money changed and just using the card as I want. I also used it at the hire car place you know, just in case they think they can charge however much they want. Loved you guys before, adore you guys now I’ve used you abroad.

I had a payment declined when trying to book flights on the Easyjet website.

I was declined trying to pay through sagepay. It was for £10. But it worked for me when the amount was £3.

This thread should be pinned to the top of the forum. There seems to be a lot of people posting about known bugs.

…Also the roadmap should also be pinned.


Starbucks app works fine for me, used it several times via the app to ‘top up’ and 3 works fine for me via mobile web.

1 Like

Card not accepted at Gunwharf Quays car park, Portsmouth. Receipt recognises MasterCard, PIN accepted, but then ‘Payment Type Not Accepted’. Thought this may be due to offline terminal, fell back to my AMEX (their app also has push notifications) - and notification received so terminal was online. Perhaps it doesn’t like Pre-pay Mastercards…

It’s my default card on RingGo with no issues…

I managed to successfully use my Mondo at a Pay at Pump Shell station after they authorised my card for £100. I spent £40. My available balance corrected itself the next day, but the transaction is still showing as £100 in the app :pensive:

It should work since I’ve always used a VISA debit before I got my Mondo card and I’ve used prepaid mastercards before with them.

Good to know, David. We might be the only 2 people in Portsmouth with Mondo cards. :slight_smile:

“Simple transactional email” appearing in email preview for login email, presumably left over from some template.

Oooh, good spot @jmap. Paging someone now!

Was double Minted today after telling me it had trouble taking the money. Currently in talks with support.

PayPal shows the username or first name last name, would be super cool if it had the PayPal logo because some merchant names are really obscure.

Had that too once but Yehudi was manning the phones and we managed to sort it out in the end. Excellent customer support from the :mondo: team!

On version 1.5 of the app, with having the "You’ve unlocked the pulse’ in the recent feed, if you press the search icon, it gives the output of:


Good spot! Have added to our backlog to get fixed. Thanks :slight_smile:

1 Like