[iOS] We weren’t able to update your balance

I have noticed I have been seeing this message most times I open the app these days.

I then have to close the app and open again and then it works.

Anyone else experiencing similar?

1 Like

Yep, me too. I have to generally go to summary and then back again to get it to update. On iOS.

1 Like

Me too. Pretty much every time I open.

Yes this is happening to me. I also get a notice stating verification required.

1 Like

Also happens to me most times I open the app — my internet connection is fine.

I keep getting this message as well. How do I fix? I’ve tried rebooting and closing and opening the app

I also had this issue for a while every time I opened the app, and closing it and restarting it didn’t help, nor did updating it. I ended up deleting the app and re-downloading it and it fixed it! I would recommend doing that if it’s still not working for you :slight_smile:

1 Like

This seems to be an issue for many people, every Monzo user I have spoken to has mentioned it. Perhaps some response from Monzo would be appropriate at this point? @simonb

I suspect that the rate of growth will have something to do with it. Darn TV ads…

1 Like

Normally shutting down the app works, although today I had to restart the phone. It could be a Monzo thing but since the latest iOS update I’ve noted little glitches in lots of different apps.

This is definitely still an issue , I’m having to take action every day too view my balance and summary.

I have never had this issue at all, but rather than rebooting phone deleting and reinstalling the app, go to settings Monzo reset session, that will get you to login again via magic link that may fix it and is quicker than the other options

Why do my fd and HSBC apps never have this issue - are they doing a periodic refresh in the background or grabbing the balance while the app loads?

Whatever the reason at Monzo, it’s annoying - I’ve not had to quit my other banking apps to get them to work correctly.

I’ve had problems with Monzo updating my balance straight away for over a month now. I’ve reinstalled Monzo multiple times, iOS from 12 to 13 to 12.

A few weeks ago I even paid for something the following morning thinking I had more money in my account and then I get hit with a balance update for that purchase and one about 10 hours previously.

It is an issue which needs fixing but I related it to the new layout beta (when I started having the issues) so stopped commenting on it.

Pretty crap for a banking app, don’t you think? Monzo needs to take a breath and fix the basic stuff first.

1 Like

Never seen this. I wonder what I’m doing differently so as to avoid it?

I’ve been getting this a bit lately too. Not a lot, but it’s noticeable as before I would only get it when I didn’t actually have any signal. I switch to summary then back and then it updates.
Seems to have been happening for the last few app versions.

iPhone X
iOS 12.3.1
Monzo - last few app versions

I have this issue all the time with the app too.

1 Like

Certainly needs some kind of response from Monzo. Do we know if they have acknowledged this issue?