App won’t sign me in with magic link

:wave: everyone,

I’m using iOS 16 and basically what keeps happening is every time I send myself the magic link to sign in to the app I click it and it takes me to the app login page again and again. I tried the mail online and made sure it’s not in the junk folder, deleted the app, reset the session via settings. Nothing seems to work. I click sign in, enter my email address, get the link, click it and it takes me back to the sign in page.

Nothing is working.

Hope someone can help.

I am currently also awaiting support from Monzo about about 2-3 days now.


1 Like

Are you using the correct details etc?

All you can do is wait for Monzo to reply to you.

Try uninstalling the app, restarting the phone and installing the app from the store, make sure not to click restore from iCloud.

1 Like

If you haven’t already done so, delete all the magic link emails in your inbox, in case your email software is trying to be clever and threading things together and you’re accidentally using an older link.

Make sure you’re not connected to any VPNs just incase this is messing with the redirection from the link to the app.


Hi Imran & welcome :wave:

Try following the hints in this section: If the permissions, camera, sound and online access are OK and you still cannot login to the Monzo App:
In this post:

1 Like

Are you using the right email address?

1 Like

I am using the correct email. It’s not in the junk folder it’s in inbox. I deleted the app. Turned it into airplane mode turned off the phone and turned it back on turned the Wi-Fi etc back on and downloaded the app again. Nothing it’s the same.

Funny thing is it’s working on my iPad same Wi-Fi, same iOS 16.1. Nothing is different.

I forgot to add Monzo support is horrible. Been waiting for support since Friday and still not response.

1 Like

Any security filtering on your phone, or maybe is it a work phone ?

Are you using the same mail app on both the iPad and your phone?

Does the link first open in Safari and then launch monzo, and is that the same as your iPad?

Nothing works. It’s my personal mobile. It works from safari to Monzo app but has the same issue.

Monzo support is just spinning in loops keeps passing me to specialists again and again. I’m so P”ed off with them.

Do you have any other email addresses?

A lot of people come on here believing that they’re using the correct email address, when they actually registered their Monzo account with a different one and had forgotten.

If it was a widespread issue we would have a bunch of posts here, it’s harder to troubleshoot when they don’t have access to your phone, but I understand the frustration.

I would try sign up for the test flight version of the monzo app.

Do you have any safari extensions?

Try pasting the link into notes for example and then clicking on it from there.

Might be worth trying to see if you can get into the emergency login page

Note if you don’t trust the link, just go to the monzo website manually to get to it

Or for short :stuck_out_tongue_winking_eye:


I was too lazy to go find it :sweat_smile:

They said it works on the iPad so likely an issue on the phone with the browser, mail client or bug in the monzo app.

It’s the correct email because currently I am “iPad banking” with Monzo since the iPhone app isn’t working. so it works there. My iPad and iPhone have the same setup, same ids etc because iCloud. Also I update them at the same time etc so I really don’t know what the issue is.

I did try the TestFlight app to see if it would be different but nope.