Fixed ✅ Amex integration - “Update access” flow doesn’t work [iOS]

Issue: I have a notification at the top of my Amex transaction feed in Monzo to update the access, presumably as it’s coming up 90 day renewal deadline.

Clicking on the notification, then clicking continue, does redirect me to the Amex app. However, as soon I am logged into Amex, it auto-logs me out, so I can’t complete the re-authentication flow.

I am using Monzo Plus.

Details to reproduce: click on the “update access’ notification under the connected Amex card and then click “continue”.

OS: iOS 14.2.1
Device: iPhone 12 Pro
App Version: 3.62.0 (latest App Store version)


I’m not sure this is a Monzo problem, more of an Amex problem? I mean, I’m sure Monzo will need to find out what the issue is, but it sounds to me like the Amex app doesn’t understand the instruction to re-authenticate, so unless Monzo are passing the wrong info to the app, it’s out of their hands.

1 Like

Yeah I’m sure you are right :slightly_smiling_face: definitely sounds like an Amex problem, but I’d assume the Monzo team who work on these integrations would need to liaise with Amex to get it sorted. Don’t think I’d have much luck if I contacted Amex about it (but I could be wrong!).

1 Like

Exactly the same issue here so sounds like an Amex problem.

It is an Amex problem. To get around it until they fix it, delete the Amex app from your phone, update the connection in Monzo, then reinstall the Amex app.

1 Like

Great thanks - worked a treat :slight_smile:

This seems to have been fixed, I did it just now and it worked :+1:
(I hadn’t deleted the Amex app as suggested above, as I was waiting to see if it got fixed first :blush:).

Yep, looks like the latest Amex app update has fixed it, I can link Amex to another apps now too where it didn’t work before.

1 Like