Amex connected account not refreshing transactions

Issue:

Amex connected account no longer refreshes transactions. The connection has been reauthorised, but transactions are not loading. I have reauthorised a number of other accounts today and they are all working okay, just Amex that is broken … has been the case for around 7 hours. …

Anyone else seeing this?

Details to reproduce:
Authorise amex account , return to Monzo app and wait for it to error…
OS:
Android
Device:
OnePlus 9 pro
App Version:
5.45.0

Screenshots:

1 Like

My Amex connection is working as it should and can be refreshed. Not the greatest news for your issue though.

Uninstall Monzo app, reboot phone, reinstall Monzo time?

Thanks for the suggestion, but it didn’t fix the issue…

It’s frustrating to think that it’s only me affected :pensive: and the thought of raising it in chat leaves me cold as they generally poor at understanding these types of problems …

Interestingly if I look at AMEX spending in trends and open a historic transaction it subsequently appears in the Amex account feed. This happens for each historic transaction that I open, but clearly I can’t do that for every transaction… :thinking:

Interestingly, I’m in the US but I’ve been having issues with only Amex as well. This makes me think it might be some setting in my Amex account that I’ll have to double check. I suggest you do too.

The balance of the account is updated correctly when Monzo returns a refresh, but the transactions are not being pulled through.

I had exactly the same problem with my starling bank transactions recently so I’m inclined to think this is a Monzo issue.

There are no settings in my AMEX account that relate to open banking.

There are no settings in the Amex app (at least in the UK) that have the slightest bearing on this issue.

Just to flag that I’m having the same issue. My AMEX balance/transaction history hasn’t refreshed in 2 days.

(iOS, UK-based)

1 Like

I have an ongoing chat which has been passed to a technical team for investigation and I have directed them to this post for further info…

I’m really hoping that it gets fixed today and that Monzo put better checks in place to validate that the open banking integrations are actually working…

2 Likes

Hi @_lewis , is there a known issue with the AMEX open banking integration? I’m not getting anything meaningful from support other than it has been passed to the relevant team, which I assume is your team?

1 Like

Latest update from support

"
Sorry to hear about the trouble!

Our Open Banking team have confirmed they’re aware of an issue with AMEX and they’re looking at resolving this today.

As soon as we have an update on a fix we’ll let you know via the chat :pray:

Thanks so much for your patience, please let us know if theres anything else we can help you with in the mean time.
"

:crossed_fingers:t3:

3 Likes

Hey :wave: Yep we spotted an issue with a new transaction field Amex started returning. We’ve made a change on our side that should allow your connected account to start working again. Let us know if you continue to have any issues.

Thanks
Lewis

2 Likes

Hi @_lewis , I can confirm that all is okay now. Thanks

It does leave me wondering how these types of open banking changes are co-ordinated amongst open banking participants. Do you get advanced notification when other banks make changes to their APIs?
I’ve had fist hand experience of breaking in Starling and AMEX in the last 2 weeks… Is this because they use non standard APIs?

I’m genuinely curios… it might even make a good blog post :slight_smile:

1 Like

I’m having the exact same issue. AMEX in the UK nominated for 2 days.

It’s fixed for me… and I assumed it was fixed for everyone … maybe try re-adding your AMEX account?

Yes, fixed for me overnight

Hey I’ve started getting the same issue 4 days ago. Looks like it’s broken again?

I’ve been having this issue the past two weeks, only my Amex account seems affected. Is there a way to resolve this as a user?

I’ve been having this problem for a month now, it’s really throwing off my budget. Does anyone know how to fix it?

This suddenly started working again today for me. After 2 months of no transactions, they are finally syncing.