Amex integration seems to be failing

Issue:

When I try to integrate with my Amex it redirects me to the Amex website.

The Amex website then gives me the option to authorise the integration.

Once I click to confirm I am happy, Amex just seems to perpetually load and I can’t see that anything has changed in my monzo account.

Ah I doing something wrong / when will this be fixed?

Details to reproduce:

Try to integrate with Amex via monzo premium
OS:

Apple
Device:
iPhone 8
App Version:

Don’t know

Screenshots:

I was having this not too long ago but after a recent Amex app update it’s all working again.

So if you’ve got an update available then it might fix it.

I had this - it seemed to be an issue when returning from Amex. I can’t remember what I did to fix it: but I think removing the card completely from Monzo, trying again and opening the link in either the web browser or the Amex app fixed it (so try whichever you didn’t). I know I tried refreshing the last Amex page after a few seconds which I think helped.

I’m up to date I’m afraid :confused:

Annoyingly, my connected accounts reached the “Requires reauthorisation” stage yesterday (after 90 days) and I couldn’t reconnect.

The only way I’ve managed to work it is a bit long winded:

  • In Monzo, go to connect your card
  • When it goes to redirect you to American Express, select “Open In Browser”
  • You may then need to select the “3 dots” on the top right of the browser window to actually open it in the proper browser
  • Now copy the link and send it to yourself on a desktop machine (I used Slack)
  • Complete the Amex verification on your desktop machine
  • When you get the “Continue on the Monzo App” page (with a url starting verify.monzo.com ), send that link back to your mobile device.
  • Click that link.

And it’s working.

From what I can tell, there’s a fault in American Express’ Javascript which is causing this issue. Perhaps Monzo Staff can investigate.

Will give this a go, thanks!!

Unfortunately I don’t get the ‘open in browser’ option on iPhone

I don’t have Plus or Premium so can’t test, but sometimes you can trigger this option on iOS through a long press on a link.

Does that work?

Nope, afraid not. The button in the monzo app takes your straight to the Amex app. Unfortunately president no and holding doesn’t offer you a different option.

I tried copying no pasting the varification link into my laptop browser once the Amex app had eventually redirected me. But this wouldn’t load, presumably because the session is broken.

1 Like

That’s a shame - it was worth a try!

Yep, thanks for sharing!

1 Like