Connected accounts (Amex) - refresh problems: duplicate/missing transactions

Issue:
My connected Amex card was showing 2 of the same pending transaction today, so I clicked on the refresh button only to find it then added a 3rd.

I then kept refreshing it, and every time I did, it added another duplicate. It was quite alarming for a moment - I worried that they were real duplicate transactions until I switched to the Amex app and found only one transaction and the correct available credit balance.

Force quitting the Monzo app doesn’t resolve the issue. I haven’t tried deleting and reinstalling - I think I’ll just wait until the transaction settles and see if it rectifies itself.

Details to reproduce:
OS: :apple: iOS 15.0.1
Device: iPhone 12 Pro
App Version: 4.1.0

I guess disconnecting and reconnecting the card may be a less drastic thing to attempt in the short term if it bugs you.

1 Like

I didn’t even think of that. :man_facepalming::joy:

I’ll give it until Monday by which point the transaction should have completed, and if it’s still not right then I’ll reconnect the card :slightly_smiling_face: (just because I’m interested to see if it sorts itself out).

It won’t stop multiples reappearing on a refresh but I’d be interested to know if it has any effect at all.

Actually just thinking about if I disconnected then reconnected the card, I would probably lose all the category changes I’ve done on my Amex transactions?

Ah. That could be grim!

1 Like

The transaction has now completed with Amex, but it isn’t corrected itself in Monzo.

It still just shows all the duplicate transactions (12 now :joy:) and no completed one.

I’m going to delete and reinstall the app now to see if that fixes it, as I don’t want to disconnect and reconnect the Amex card in case I lose all the category changes etc I’ve done.

Deleting and reinstalling the app hasn’t fixed it :sob:

I was hoping the 4.2.0 update today might just randomly fix it but no luck :slightly_frowning_face:

Does anyone know if it’s possible to renew the connection of a linked account without removing it and re-adding it? I really don’t want to lose all the categorisation I’ve done for my Amex transactions :pray:

I have a bug with mine where the refresh button doesn’t work and I often have missing transactions.

I resorted to removing and re-adding, and I’m 90% sure it didn’t lose all my categorisations.

I only remember categorising once, and looking back I can see historic are all correctly categorised.

Edit: didn’t actually solve my bug though!

2 Likes

Yeah the Amex integration seems to be pretty broken recently. Refresh doesn’t even do anything for me, just spins forever. Barclays refresh is almost instant.

1 Like

Same! I thought it was just me.

2 Likes

Thanks for alerting us, we have identified a couple issues with the Amex integration and are actively looking into them.

7 Likes

Thanks @albertmonzo, good to know it’s being investigated :slightly_smiling_face:.

I found out I could go through the flow of connecting my Amex card without actually disconnecting it first, which refreshed the connection and got rid of the 12 duplicate transactions it was showing, but it didn’t replace it with the now completed transaction. The transaction is just totally missing now, like @Toblerone and @BristolMatt have experienced.

2 Likes

We think this is caused by not having used your Amex cards for 3 months or more, then using it in the current month. Is this the case for you?

This isn’t the case for me. I use my card constantly. Hitting refresh does nothing, just endless spinning.

It does seem to update overnight though.

1 Like

Nope, I used it last month and it was fine (I had a few transactions in September).

I also use mine daily and am having issues with the integration

Apologies I wasn’t clear, there are two distinct issues:

  • Duplicated pending transactions and/or missing recent transactions but the account refreshes successfully (we think this is caused by the scenario I laid out above)
  • The account never refreshes and so is stuck with an old state (every transaction since the last successful update is missing).

We’re working on fixes for both issues and will keep you updated. Let me know if your situation doesn’t fit one of the two scenarios above.

4 Likes

Hey @albertmonzo sorry, I might be misunderstanding, but I’m not 100% sure I fall into either of those exactly.

My issue is the duplicate/missing transactions. The refresh button works in that it didn’t just keep spinning, it updates to “refreshed just now”, but doesn’t resolve the duplicate/missing issue. But I have used my Amex card within the last 3 months so I don’t fall into that scenario - used last month a few times and all transactions from then are showing.

Every time I hit the refresh button it added an additional pending transaction - until it hit 12 which seemed to be the limit.

I didn’t disconnect my Amex card, but going through the flow from “other accounts, in monzo” to add it again removed all the duplicate pending transactions, but didn’t replace it with the completed transaction hence it now being missing.