[Feature Request] App Switcher should hide contents of Monzo account


(Andrea M) #1

This should be a mandatory feature for all banks but very few do this:

Summary: the app switching view on phones should NOT show contents of app.

Current behavior [iOS as example]:

  • Use Monzo app
  • Press home button to go to home screen
  • Open another app
  • Double click on home screen to quit current app
  • Monzo preview shows all contents, especially when I close the current app as Monzo preview is fully visible

Desired behavior:

  • Use Monzo app
  • Press home button to go to home screen -> Monzo app automatically updates the app snapshot to just show the monzo logo
  • Open another app
  • Double click on home screen to quit current app
  • Monzo preview in the App Switcher does not reveal any information
  • Happy user :slight_smile: Hurray privacy!

An example of an app that does this well is LastPass.

Example of the App Switcher view I’m talking about (from the Apple marketing page):


(Change Works) #2

I think that’s a bug. I have an iPhone 6 on iOS 11.2.2 and cannot replicate this. On another thread I think it was mentioned that the bug can be squished by uninstalling and reinstalling the app. HTH


(Andrea M) #3

So your version of the app hides contents when you toggle the App Switcher?
I’ve tried it just now again just to make sure and it doesn’t hide anything


(Change Works) #4

Yes it does. Every time.


(Andrea M) #5

Ok, will try re-installing then :slight_smile: Will update results here


(Change Works) #6

I think on the other thread the user was using an iPhone 7 plus if that helps.


(Andrea M) #7

I’m using a 6S. Also noticed I haven’t updated to the very latest release 11.2.2 so updating now just to make sure. For what it’s worth, on 11.1.2, even with a fresh re-install, it doesn’t fix the behavior.

Updating phone to 11.2.2 and will try again.


(Colin Robinson) #8

iPhone X 11.2.2


(Andrea M) #9

Great. Fastest implementation of a feature request ever :slight_smile: In negative time! Phone is updating as we speak and will refer back with results.


(Change Works) #10

Found this


(Alex) #11

I wish this was a preference that could be enabled or disabled.

Infrequently I need to copy my account number + sort code into another app which doesn’t allow pasting and so I use this app switching view so I can peek at the numbers without having to fully switch between the apps.


(Peter Roberts) #12

On android the view is not obfuscated in the task switcher and I like it that way. So I do hope that if this is added it is configurable

Really annoys me that Starling does this and I can’t turn it off! Or the locking every time I change app!


(Andrea M) #13

Unfortunately it’s still not working, on iOS 11.2.2 I still see the app contents in the App Switcher.

Also agree it should be a toggable setting!


(Colin Robinson) #14

But it is working on 11.2.2 for me so that implies something else is the cause?


(Richard) #15

You can disable it for 15 minutes under the Enable Screenshots setting.


(Andre Borie) #16

I wonder if it’s having to do something with how long the app has been in the background. What happens if you leave the app like for 10 minutes?


(Nicholas Martin) #17

Just to add that the functionality works as expected for me. If you’re on the app and double tap home, it’s visible, but as soon as Monzo goes to the background (press home or use another app) then Monzo gets hidden.


(Andrea M) #18

I tried leaving it for 30-60 minutes, and it still shows contents. I tried using LastPass to see if it was an issue with my phone and that still works instantly: contents are hidden as soon as I try to switch apps.

Wonder if it’s a bug with my Phone 6S (iOS 11.2.2) + app combination or perhaps influenced by specific system settings?


(Andre Borie) #19

Do you have power saving mode enabled by any chance? I really can’t see what could be causing it; mine definitely works on iPhone 7 running the same iOS version.


(Andrea M) #20

Nope, I do have some accessibility options active like Reduce Motion / Increase Contrast (to save battery), but tried disabling them and restarting the app and all, but no change.