Delayed Gmail Notifications ( android )

Does anybody know how to rectify this or is it something i have to live with ?

Send an email to myself and it comes instantly however the notification comes 3 minutes later ?

thanks

Try turning ‘unrestricted data usage’ on for Gmail and turn off battery optimization.

It’s likely not allowing the app to check for emails as often to save battery.

1 Like

I’m sure ive already tried that, where do you find " unrestricted data usage "

In ignore battery optimisation, gmail isnt listed. All the apps in there are set to not optimize

1 Like

Ok i clicked on " data usage " which is the closest thing i can find, and "mobile data " " background data " and " roaming data " are all enabled

Seems to be worse in the evenings, any ideas ?

What phone is it?

Huawei Y7

There’s a 250+ page long of people on Samsung getting the same issue.

Yes but huawei are known to be especially bad

Try this

Huawei: Phone Manager App > Protected Apps > Add monzo to the list.

Monzo ? My monzo works fine, i’m on about Gmail mate

After googling " delayed gmail notifications " theres pages and pages of people with this issue :frowning:

Sometimes they come in and notify me immediately, sometimes not. Really odd

Sorry half asleep try

Huawei: Phone Manager App > Protected Apps > Add gmail to the list.

It’s common with other phones also but that might help

1 Like

Thanks dude but there is no option for " protected apps "

Oh what lists are there in the phone manager ? Look for Gmail in all of them and allow

Clean up
Mobile data
Blocked
Battery
Drop zone
Virus scan

And Gmail is not in any of them