Can't add card to Tesco Pay+, fails at 3D secure


Details to reproduce:

Try to add a card to Tesco Pay+'s app.

3D secure warning displays an error.

iOS 14 Beta

iPhone XR

App Version:
Tesco Pay+


Update: Tried this with both a virtual card and my new Plus card. Both won’t add.

Is it maybe a problem with 3D secure and your beta version of iOS? Have you had success with any other cards? thus ruling out an issue with the Tesco app?

Hm, very good shout! Tried it with my Tymit card and that’s getting an internal server error, albeit not as nicely styled as Monzo. Something weird going on.

I’ve just successfully added a virtual card to the app. Im on 13.6 though.

It may be IOS14 I tried and has same issue, then tried on my android backup phone and it worked fine.

iOS14 issues will not be priority fixed yet as it is an unreleased OS. The Monzo app wouldn’t work for weeks at all when the iOS13 beta was released.

If you want it to work, then you will need to downgrade to iOS13.6. Monzo will test iOS14 and fix the bugs ready for release in September.

1 Like

But we don’t know if it is a IOS 14 issue.

1 Like

Spoke to Tesco on Twitter and they seem to think it’s a bank issue (which I think so too)

I added monzo to Tesco pay+ before just fine.

I had to click and “use SMS authorization” rather than the biometric in-app one. It seems like Tesco pay+ doesn’t like out of band authorization.

Just tried adding my Monzo Plus card on iOS 14 Beta 2, seems to work okay now.