Bill payments still show deleted pot as source (Joint Account)

Issue: DDs & SOs still show deleted pot as their source (Joint Account).

Details to reproduce:

  1. Create a locked pot
  2. Set one or more of your DDs or SOs to be paid using the funds in that pot
  3. Go to the pot and delete it
  4. Go to Payments -> Scheduled

DDs and SOs show that they are paid from your account balance - without the little pot icon in their icon corner.
Payments are showing to be still funded by the deleted pot and still display the pot icon in the corner.

OS: Android 11 - 1st October 2020 Play Update
Device: Pixel 4XL
App Version: Version 3.63.0


Hi Brad & welcome :wave:


  • Exit the Monzo app (don’t logout)
  • Long press on the Monzo icon on your homescreen/app drawer and then tap on the circled ‘i’
  • The app info is displayed, tap on ‘Force stop’, then OK
  • Go back to your homescreen/app drawer and launch the Monzo app

Is the problem still there?

Saw this reported before.

When I do that I get two options.


Send money

No “I”

I am also on android

Here’s a screenshot of the results of a long press: the ‘i’ is at the top-right of the selection pop-up:

If you don’t have it displayed with a long press, go to Settings/Apps and notifications/See all apps/scroll to Monzo & tap on it

1 Like

Hi David,

Thank you for getting back to me!

I have followed the steps to Force Stop the App and it has not rectified the issue.

Kind regards,

Thanks for the follow-up. In that case, do the same thing, but instead of tapping on ‘Force stop’, tap on ‘Storage and cache’, then tap on ‘Clear cache’ - then back to the Monzo app and when in ‘Home’, tap on ‘Payments’ and then ‘Home’ again. This generally refreshes any display errors.

If it still shows incorrectly after these trials, it’s likely to be a :bug:

1 Like

I just tried clearing the cache and that has still not rectified the issue.

Followed those guidelines, however, saw nothing to tap to switch on that particular function.

All notifications, via android, are switched on.


On Starling long press, I get offered Payments or Customer Service.

Try solution at end of this thread.

Does seem like a glitch though.

Yes, just had another look at the process and it does look like you need to deselect the pot direct debits are associated with before you delete the pot.

So, no need to create a new pot, just link to an existing one, confirm it, come away from that screen, then repeat process to deselect.

I know that will work as I’ve just done it.

1 Like

Seems like a potential workaround - but a bit laborious.