Approve transaction gives blank page

Issue: I bought something online. They did a card check. An android notification popped up, but as I had the Monzo app open anyway I approved it in the app. Now I can’t get rid of the notification. If I click the authorise button it just gives me a blank screen, if I click the cancel button it wants to know why I’m cancelling the transaction - But I don’t want to cancel the transaction, I’ve already authorised it, I just want to get rid of the notification.

Details to reproduce: follow the steps above. It’s done this before in exactly the same way. The only way to fix it & get rid of the notification is to reboot.
OS: Android 11
Device: Pixel 3a
App Version: 3.90.0


Have you tried re-installing the app? Have you tried quitting the app via multitasking and reopening it?

If it’s the Android system notification, you can just swipe it away.

ETA: the above has been my experience, but following multiple reports now I accept there may be circumstances where this isn’t possible.

Some you can’t. You have to restart the device to get rid of it/them.

1 Like

I find just stopping the app and then clearing cache is enough to get rid of that annoyance, granted it might not be the same for every user.

1 Like