App will not let me post a profile picture

Issue: Any picture that I attempt to post as a profile picture will not be allowed, with an error message: ‘There was a problem. Response status code was unacceptable: 403’

Details to reproduce:
OS: 13.3.1
Device: iPhone 7
App Version:


Have you given Monzo permission to access your photo gallery?

Secondly. When weird things like this happen a good old reinstall usually solves it.

  • Remove the Monzo app
  • Restart your phone
  • Reinstall the Monzo app

Response 403.


  • logging out then logging back in,
  • using 4g instead of the WiFi

If all fails

Reinstall the app :slight_smile:


I have tried all of the things that you have suggested but still nothing has worked!

1 Like

What type of image are you trying to upload?

I’m also having this problem. I can delete the image, but when I try to upload a new one it fails with an error.
I’ve already uninstalled and reinstalled with the same error.

I am also experiencing this problem when trying to upload a profile photo.

This is a known bug at the moment unfortunately (a fairly new one!). Feel free to pop us a message through the in-app chat if you’d like us to make a note and give you a shout when it’s sorted.