Anyone else seeing API errors for pot moves

I am getting a response of

{“code”:“internal_service”,“message”:“An error occurred processing the request”}

I am still getting these - I can retrieve the list of pots (although can only see my personal ones and not my business accounts - but this was the same before).

My app has had no problems moving money in and out of pots since this topic was started :neutral_face:

I have no problems on the app either - this is all via the API from our backend system (we move money into different pots as money comes in)

Sorry, I meant my own app that uses the API for automation rather than Monzo’s mobile app :smiley:


I am wondering whether some of the prep work for the launch of the business accounts has broken the Pots for business accounts.

I am guessing that your’s uses personal pots?

Tagging @jackcully to see if has any ideas

I’m using it for both solo and joint accounts but not business.

The official client uses this same API so if it’s working in the Monzo app it should work for us (barring permission issues).

I thought maybe my source IP had been blocked, but I have tried it on a box in another data centre and have the same problem.

It’s just timing out after 30s from there :frowning:

OK, this is getting more confusing

If I make the request through the playground - it works. Invalid credentials, I thought

So regenerated my token and still no joy.

I am at a bit of a loss!

It’s worked for weeks

Hey @aarhus! Could you possibly DM me your email address? I’ll take a look at this for you :blush:

Turns out it was due to issues with duplicate dedup_ids. This was a knock on from when stripe had payment issues on Monday - they had notified us that the payment was in our account but it wasn’t there!

Thanks Jack