✅ [Android] Online payments failing

Issue: This has happened to me twice now - once with British Airways (just now), and once with Sainsbury’s Home Insurance (one week ago).

Details to reproduce: I enter my Monzo card details, I press ‘buy’, and it brings up the Monzo screen saying to confirm in the Monzo app. The notification comes up on my phone and I type in my pin to confirm. I go back to the merchant’s website…and they tell me that the payment has failed. In the first case (Sainsbury’s), the payment was actually taken, then refunded (I can still see the transactions in my list), whereas the British Airways payment didn’t make it to the transactions list. Note that there was enough money in the account to cover the payments.

OS: Android
Device: Pixel
**App Version:**I’m struggling to figure out what version of the app I’m running…

Screenshots:

And…I’ve just now had a problem with signing up to Santander Cycles with my card. The Monzo app says Santander has taken £2, but the Santander app says the payment method isn’t valid. When I tried the second time to set up my account, it said the card is ‘in use’, but wouldn’t let me create the account. Tried logging in anyway and it doesn’t recognise me - so it’s taken money but won’t create the account.

Hi @MFischer have you raised via inapp chat or help@monzo.com for further investigation?

1 Like

I haven’t. I just used another card, then decided to raise the issue here. :wink:

I’d raise it with Monzo directly in case it’s something account related.

2 Likes

Monzo will at least be able to confirm that you went through the full approval flow etc. while we’d only be guessing about what may or may not have happened.

5 Likes

Had this twice with Scottish Power. Both times got the 3D Secure screen at their website and approved it on my phone only to get a failure at their website

Both showed as pending on Monzo, but I am guess they would have been refunded automatically after seven days had Monzo not helped me through reversing them both the next morning

Does not make me feel that comfortable with 3D Secure I have to say, but cannot say where the problem lies

I had a few issues but changed to SMS code instead of tapping feed and it’s all been perfect since

I too actually had 3D secure fail on me tonight when using in app authentication. Didn’t try sms option.

@rika any known issues?

1 Like

Only appears to be an issue with SMS messages at the moment

https://monzo.statuspage.io/