[Android] Adding a receipt not working

Issue: Adding a receipt using the camera through the app doesn’t work. I left the app open and running for a few minutes and the process never finished. When adding a receipt from device folders the image loads within 30 seconds, which I think is still a little slow. This used to work but has been an issue for a good few months now.

Details to reproduce: Try and add a receipt using the camera through the app.
OS: 9.0.12
Device: OnePlus 6T
App Version: 2.39.0

Screenshots:

That’s annoying :see_no_evil:

I’m on 2.39.1 (Android Q, Pixel 3XL) and it works fine for me :ok_hand: both adding from local storage & taking a photo :camera:

See below (photo of my desk & screenshot of Inbox by Gmail - both added to a transaction)

I’d give re-installing the Monzo app a go :slight_smile: it’s not perfect but it might be the solution to this glitch :grin:

Thanks for your suggestion. An interesting development has occurred. I uninstalled the app, rebooted my phone then installed the app again. Now the image will upload after 1 or 2 seconds however, I first thought this function was working even worse than before. After the upload is complete the “take a picture” message is displayed again and there is only one radio button icon at the bottom. I took this to mean it hadn’t worked. When I backed out of the transaction I saw there was an image after all. I had actually uploaded an image 3 times (I tried 3 times) but the landing page after the upload was complete had no indication anything had happened. The same is true if I delete an image. I tap “remove image” and am taken back to the same image. Only backing out of the transaction and going back in will show the image has been removed. A slightly different issue now and a much more minor one but a little bug nonetheless.

1 Like

I can reproduce this :slight_smile:

After uploading a photo you’re still presented with the option to upload a photo :joy:

If you go back to the transaction screen (after uploading a photo) then back into the receipts page, you’ll see the receipt you uploaded :yum:

Definitely a little bug there haha :boom: good spot! :bug:

2 Likes

On my S9 I can reproduce that on a direct debit transaction. However, on an Amazon purchase I made, I didn’t get this issue but instead got prompted for my fingerprint after taking the photo. Once the fingerprint was provided I got taken to the receipts screen which correctly displayed the photo I had just taken.

I used to get prompted for my fingerprint to login after every single photo upload. I actually turned off having to login to the app using any security as this was so annoying!

1 Like

I almost did the same due to the 3DS implementation (considering that the 3DS process requires a fingerprint itself too…). It is pretty annoying sometimes :smiley: