A Conundrum For The Tech Experts

In our house we have a Vodafone broadband router.

On my wife’s Apple account there is an iPhone SE and an iPad.

On my account there is an iPhone 13, an iPad, an old iMac and an Apple TV.

My iPhone and iMac continually disconnect from the router (about 4 times a week), but they don’t reconnect because they forget the password.

Anyone have any idea why this happens? It’s not the router (other devices work fine), it’s not the iPhone (because other devices are affected), and it’s not the iMac for the same reason. My iPad occasionally disconnects and has to be reconnected, but much less frequently. Neither the Apple TV nor my wife’s devices have ever been affected.

To be honest it’s more of a PIA than a real problem (except the iMac always asks to join my iPhone hotspot when I log on).

I’m at a loss to explain it, but I’m out of contract with Vodafone so they are due a call, and last time I renewed they sent me a new router anyway.

Have you tried resetting Network Settings on the devices & seeing if that helps?


Sounds like your Keychain is a bit borked. I would have all devices up and working in front of you and quickly remove the wifi details from each then add you phone back after a couple of mins (it hopefully will sync via mobile data) and then add the other devices.
Also double check Keychain sync is on across the devices for iCloud. On Mac you can actually look at your keychain and remove entries.

Also I would check if your router has WPA3 and if so turn that off for now. I lot now come with a mixed mode WPA2/WPA3 and its supposed to use whatever is supported but mixed mode can cause these password issues especially when you factor in Keychain sync.

I think this can wipe all saved wifi points if I recall but its maybe different now. I would clear the entry first.


It still does. Definitely worth trying other things first.


Maybe try to login to the router and change the WiFi name, should rule out the keychain issue also unless it’s the wpa2/3 issue.

Vodafone have had their current router for a while so you may not get a new one.

1 Like

I have just done that. Thanks :pray:

Done. Thanks.

I’ll give that a go in a few days if the other suggestions don’t work. Thanks.

1 Like