Google Play Unable to Verify Bank

Hi all,

Has anyone been having issues verifying Monzo through Google Play?

For any payment attempt I receive the following error after approving the payment in the Monzo app:
Cannot verify this card with your bank. Try again or contact your bank if this issue persists

Thanks

Is your card frozen at all? And are your address details accurate in google pay to reflect those in Monzo?

May also be worth removing and adding the card again to make sure all is well.

1 Like

No frozen card and checked all the settings, everything matches.

It has been working fine up until the last week or so, just thought it was a temp glitch but have now tried all cards and new virtual card and same error?

Can you use the cards otherwise ie physical?

As it sounds like a google issue otherwise.

May be worth dropping by chat and explaining.

I’m off today so can’t see if any direct issues to report, but a week long seems to indicate it may be something your side (not blaming).

Does google have a help section or contact area?

Thanks. Will do some digging and testing my end to see if I can get to the bottom of it.

If not, I will raise it in chat and see if I can contact Google too.

1 Like

I’ve had a couple of Google pay contactless payments declined now in last few days.

Other cards work fine.

Are these in person payments or Google pay on a website?

Are you sure your card isn’t frozen in the app?

Yeah card isn’t frozen. These were in-person payments (Tim Hortons and local Co-Op).

Still no luck after some testing, removed cards, added new Virtual Cards and all transactions from Google Play Store all error.

I added my Starling card for the same purchase and approved the transaction, all worked as expected.

This seems like a link between Google and Monzo for me so will raise issue in Chat.

1 Like

definetly contact in app chat so they can look at the logs for you.

Seeing the same issue with Monzo on Apple Pay at the moment. Not sure if it’s related to this, or because I have a new card pending. (App is latest version from TestFlight)

1 Like

Most likely a new card pending - I’ll look for the old thread that came out last year. Essentially people got this error if they ordered the plus and premium. Their was a easy fix too but I can’t remember at the top of my head

1 Like

Is probably just a coincidence then. Is ok, I’m not in any rush.

1 Like

While I’m looking for it:

Have you fully removed the old card and disabled any vpn if one is active.

For me? No VPN & gone from Apple Wallet on all devices. Just waiting on the new card arriving still so technically on the old one in-app still. I’ll avoid hijacking Wheatley’s thread any further. :wink:

1 Like

I have had to use other cards when paying for google play stuff for a few days now… something is borked, you just get an error message.

Similar issue with cleverbridge, for some reason. They throw up an error saying I haven’t enabled SCA and to contact my bank.

Have had the following back from Chat:

We are aware of a problem that Google Play and Google Pay are having with multiple banks at the moment and we currently have engineers looking into this for us. In the meantime, can you please try the following
Try updating the app you are paying with (i.e Google Play etc)
Clear the app cache (you can normally do this under Settings > Apps)
Update the app requesting the payment and clear it’s cache too
Update the Monzo app If this doesn’t fix the problem then unfortunately we may not be able to help any further until our engineers have finished looking into the problem.

Have tried the suggested so it will be a waiting game.

1 Like

If you’re on TestFlight it won’t work