Unable to open live chat

I’m trying to open live chat to initiate a name change, however whenever I try to open it I get a spinner and nothing loads. The bottom of the screen flickers as if it’s constantly reloading something.

Things I’ve tried:

  • deleting and reinstalling the app.
  • restarting my phone.

Is there another way to get to the live chat feature?

It’s never live chat, just chat.

Help > Contact support > Contacting support > Tap here to get started, and run through the options.

Is that the steps you’ve taken?


It’s never chat tbh, more penpal.


Getting the same thing when trying to load chat… @AlanDoe something you can raise the flag about internally? :checkered_flag:

Is this an iPhone issue? As I followed my steps and got connected to someone straight away.

Ya, I’m on iPhone, latest TestFlight, and it’s not loading :frowning_face:

not that I need support… well, not Monzo’s anyway


It’s a while since I tried chat (Android) - and I’ve not had the Chat button for years now - but when I try to get into chat now (via searching for ‘Contact Support’), I’m getting several filter question screens which I’ve never seen before:

I’m on Android. I’ve gone to the support page for preferred name change then tried opening chat from the link on there. I’ll try another page…

I searched for “contact support” and got to the chat that way. It might just be the link on the change name help page.

That worked for me earlier. Must just be having a moment for you.

They’ve been around for a while.

Absolute pain when all you want to do is look at previous messages.