Trying to log in


(David Langford) #1

Hi my app is playing up. I am trying to log in but it keeps taking me around in circles. Can’t go through my email as that keeps going to the instructions of see email ggggggrrrrr

Please help

Dave


#2

I’ll say it before someone else does… Have you deleted and reinstalled the app?


(David Langford) #3

OK I will try that


(David Langford) #4

OK tried that and it says didn’t work but don’t know why WTH ???


#5

What OS are you on? Android or iOS?


(David Langford) #6

Android! !


#7

Say no more! :joy: (joking…)

Someone from Monzo support should be along soon!


(David Langford) #8

Cool. Signed up ages ago … I have used my account loads then this just happens !!


#9

Make sure you’re using the right email and if it still doesn’t work email help@monzo.com and they’ll be able to help :+1:


(David Langford) #10

Yes and done that but it doesn’t help me now grrrr


( related to Monzo CEO, Investor in Monzo ) #11

have you tried deleting ALL the “login to Monzo” magic link emails in your email feed (s) ?, delete your Monzo app , turn off your phone , turn on your phone , re install Monzo app then sign in and use the magic link that comes through ?


(Marcel Ruhf) #12

When did you sign up though? Do you have a Monzo Current Account, or did you sign up during the prepaid era?


(Kevin Perkins) #13

Don’t like this email way of logging in. I can’t get my email on my phone without clogging it up with crap. It is based on a domain name. So I can’t log in.

Can’t get in to change the email address either. Effectively I’m locked out of Monzo.

At least it has sorted out my heirarchy between the card trinity of Starling, Revolut and Monzo.

Through Darwinism, Monzo is now distant bottom by way of shooting itself in the foot. Back to being a travel only card. May as well have stayed as a prepaid card.


(Sufi) #14

You can ask for help via email help@monzo.com - COps can change email address for you.


#15

Hey @stagford, did you get this sorted?

And @kev_p we can definitely change your email address if you email help@monzo.com, we’ll just need to complete a couple of bits of verification!


(David Langford) #16

Hi

Yes I believe by deleted the app and reloading it a couple of times did the trick

Many thanks

Dave