Terminal Decline : Why Some Payments Fail


(Naji Esiri) #1

(Peter Day) #2

Awesome read! Thanks so much for sharing. Love the subtle “Unable to blink” animation on the POS Terminal :smiley:


(Alex Sherwood) #3

One of the other issues we see fairly often are offline transactions (which are mentioned as “When a merchant doesn’t send an authorisation request” in the blog post) being declined.

I know that this issue will go away when the debit cards launch but it might be useful if you could confirm that if a user’s transaction is declined (when they try to pay at a parking meter, for example) & they don’t see an error message in the app, that’s usually (though not always) the reason - is that correct?


( related to Monzo CEO, Investor in Monzo ) #4

maybe also worth a Monzo member of staff qualifying this query on Facebook post as well


(Stephen Early) #5

Very interesting.

I had a transaction declined today which failed to show up in the Monzo app at all. It was for 50p, with £10 cashback. The terminal went online and came back with “Not Authorised”, which is odd - if it was declined I’d expect to see it in the app.


(Alex Sherwood) #6

Cashback isn’t allowed for the prepaid cards -

But it will be for the debit cards :tada:


(Stephen Early) #7

Oh, right. I suppose that must have been the first time I’ve tried it! So that’ll have been rejected at some layer before it got to Monzo?


(Richard Owen) #8

My favourite decline (What am I saying?? - FML!) was last year paying the Dartford Crossing charge. I called the “Dart Charge” call centre and paid over the phone a few mins before driving over. I gave the card details and both me and the call centre lady ended the call, quite satisfied.

However she must have mis-heard or mis-typed the card expiry date. 2 seconds later got a Monzo notification: “Declined, the expiry date was wrong”. So I was able to call up straight away and explain that my payment hadn’t worked. So I was able to pay again - properly!

If I hadn’t have been notified of this I would have crossed the Dart in ignorant bliss, enjoyed my 2 week holiday in France and then come back to a penalty charge. OK I might have been able to plead my case as the first call was probably recorded, but it just saved me any hassle and I was over the moon.

Thanks Monzo.:ferry::beer:


#9

Fascinating read, thanks a bunch for this!


(Martin B) #10

Great post. Thanks for sharing!


(Miguel Afonso) #11

I suspected the process was something like this.

When I was in Portugal earlier this year I used my Monzo card on a self-service fuel station.

One thing I noticed as soon as I authorised the card (but even before starting to fuelling up) was that I got a notification on my mobile saying the pump had just charged me for the equivalent of 100€.
When I then finished fuelling up the pump credited the difference.

I understood this a being a security feature for the pump station to avoid being declined an amount after the fuel was dispensed.

But before, on a previous occasion, I was really confused with this next sequence.


#12

There is one shop, where every time I try to use my Monzo it fails with “Not enough TIDS”, yet every other card I have works there… Any idea what that means and why it happens only with my Monzo?


(Naji Esiri) #13

@VaticanUK TID stands for Terminal ID, they are used to obtain authorisation from your acquiring bank when you try to make a payment on your card.

Each TID can only process one transaction at a time with the same currency and card type. This return code suggests that the TID configured to the payment terminal was busy processing another payment with the same currency and card type when the request was sent.

It’s worth waiting a few seconds and trying again in any case! I’d be interested to know if this works after a second attempt :thinking:


#14

Sorry only just saw your reply (and I guess it’s irrelevant now, but to satisfy your curiosity…), I get the same error every time with my PP card, not matter how many times I retry, and on every time I visit that shop!

My CA card works fine though!


(Andre Borie) #15

I wonder if prepaid cards need to use different TIDs than normal cards and they happen to have no prepaid-capable TIDs configured, thus causing the error.


(Neil) #16

I had two transactions declined in a bar last night. Tried Contactless first then using my Pin - same result. The barman just shrugged and was a bit peed off as it was a busy Saturday night. I had to go and find my wife to get her to pay.

There is no information in the failed transactions on the Monzo app. This isn’t the first time it’s happened. Each time I’ve had adequate balance. Using the Current Account feels like a roulette wheel :frowning:


(Jolin) #17

Have you contacted in-app support when this happens? They should be able to provide greater insight as to the cause, which might avoid this in the future.


(Andre Borie) #18

If there was no notifications in the app this means the request didn’t even reach Monzo. Most likely a fault in the terminal or their internet connection.